Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
SL500, ML320, E320
Joined
·
538 Posts
Discussion Starter #1
Greetings from Arizona:
Periodically, when turning on lights or activating turn signals on our 92 300SL, all the dash warning lights flash, guages go to zero and immediately pop back- leaving the seatbelt light flashing for a few seconds-- operating characteristics are not impaired..doesn't matter if car is running, or if ign key is simply `on'.. it would seem to have a short someplace, but am unsure where to start - - dealer says, just replace the gauge cluster for two grand - - I'm thinking a grounding wire somewhere... Would appreciate any thoughts.
 

·
Registered
300SL
Joined
·
9 Posts
Dash Flash

Hi,

Couple of possibilities. Overload on one of the voltage regulator chips, microprocessor resets. If tachometer, speedometer, fuel and mph gauge go to zero, check the L4785 mounted on the heatsink.

Other common problem on these clusters is solderjoints just giving up over time, resoldering around powersemiconductors, power resistors and connectors is not a bad thing to do with intermittent problems.

Grounding wires and battery wires are doubled up. Unless both wires are failing at the same time you should be OK there.

Hope this helps,

FWIW, my last repair on a 300SL cluster was only last week. Tachometer, speedometer and couple of other gauges went "wild". Crystal for timing circuit failed, 2 hours and $0.59 later I was back in business.
 

·
Registered
SL500, ML320, E320
Joined
·
538 Posts
Discussion Starter #3
Thanks !

NPI-- thanks for the reply . . .I was thinking in terms of a simple ground, but what you suggest makes better sense . . .thanks for taking time to reply - - I appreciate your advice.
CQRT
Arizona
 

·
Registered
91 300 sl red/pala
Joined
·
21 Posts
flashing lights

Hey hope this helps; Have you recently replace the compartment light underneath the pass or drivers side?
or removed them for some reason? I did that once(took out the bulbs) and forgot to put them back in. I went driving with the wife and she accidentally kicked the leads ( unbeknownest to me ) dash started flashing, guages went nuts, I was like what in the world is going on with this car!!! check those leads first!!!!
You can also check if you have done any upgrades to the radio. happy hunting

Lewis
 

·
Registered
SL500, ML320, E320
Joined
·
538 Posts
Discussion Starter #5
Thanks Lewis - - I haven't been exploring under the dash, so I'm not mindful of any such...

Thanks Lewis - - I haven't been exploring under the dash, so I'm not mindful of any such kicked/pulled wires-- but I'll certainly check - - it's an excellent suggestion. I'm worried that if gone unchecked, one day the dash will flash, the car will stall and I'll wish I took someone's good advice much, much sooner !
regards-
Rollie
 
1 - 5 of 5 Posts
Top