Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1998 ML 320
Joined
·
44 Posts
Discussion Starter #1
so friday i was driving back from school and while turning it was jerking like the rev would go up and then down then up and then downn again...like if you were pressin the pedal, then pausing a sec and doing it again..but it was doing it by itself.

so the next day i drive it again and it wasn't doing it as i rolled out of the driveway but now it keeps doing it like it wont change gears, it'll keep jerking back and forth, back and forth..won't change gears or anything, it just keeps jerking..so before i take it to the dealership any suggestions or anyone else have the same problem....recommendations or help???!!!!

its a 1998 ML 320
 

·
Premium Member
02 ML320 06 ML500
Joined
·
17,104 Posts
You probably have a dirty Throttle Actuator or dirty MAF sensor or both. Remove the MAF sensor insert by removing the two screws pictured in photo #7 of pdf (one above and one below the elec. connector) and spray clean the wire with CRC MAF spray cleaner, APPROX. $6 DO NOT TOUCH THE WIRE WITH ANY OBJECT. Just spray the wire until it is shiny, let dry and reinsert.

Note: the two screws require a special socket that you do not have, so either use a pliers or cut slots in the screws so you can use a flat tipped screwdriver.
 

Attachments

·
Registered
1998 ML 320
Joined
·
44 Posts
Discussion Starter #3
well thanks a lot for the info man, but i got it on to a hoist and discovered my cat is clogged the passenger side second one...so i will have to get that replaced thanks alot.:surrender:
 
1 - 3 of 3 Posts
Top