Mercedes-Benz Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
I have a 2003 Clk320. Love the car, but the ESP, take to workshop warning is on. I made the mistake of using a iCarsoft MBII, coming up with a steering angle sensor fault. I then, (to my headache since) started running a steering angle test, road test. Next thing i know, I have warning after warning popping up! BAS, ABS, ESP, SAS,... I understand that you MUST complete the road test, as described by scanner. I went to parking lot, and completed the road test, as "I read it". All warnings went off, and ABS light also went off. Restarted--- SAME DAMN THING! Upon restarting, all warnings came back up! Attempted road test 4 more times, all with same result!

I dont understand, what am I doing wrong??? I got all warnings to go off, as described in "road test" steps, but they come right back on upon restart! Since the instructions are rather vauge, and non-specific, I attempted a variety of ways, including- getting to 6mph and then cornering to full lock for 1/4 turn, 6mph and cornering back and forth then cornering to lock for 1/4 turn,....

HELP!!!?
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
Do you mean clearing faults? If so, have done that. But still have one fault- steering angle sensor. Have attempted the "lock to lock reset" numberous times, to no avail.
 

·
Registered
1999 E320, 2000 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Joined
·
2,734 Posts
Do you mean clearing faults? If so, have done that. But still have one fault- steering angle sensor. Have attempted the "lock to lock reset" numberous times, to no avail.
What was the fault code? Maybe your steering angle sensor is actually bad.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #5
Im going to try the roadtest again. Im thinking im taking it too cadually/slowly. Im going to try to do it all within 10 seconds. The steps of the road test are very vague and unclearly worded, so im not sure I've followed correctly. Do i have to stop, turn off engine for a period, then restart, after roadtest? As i said, the roadtest's ive done have been semi-successful- in that it has turned off ESP light and all warnings (ABS, BAS, ...) have cleared. But all return after restarting engine. I do believe SAS needs replacement, in that, all else has failed to clear ESP, but my issue is the "road test mode" or "diagnosis" error on all systems that wont clear, evrn after following roadtest instructions, and all clearing, only to return after restart.
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
19,364 Posts
This is a problem that has been reported several times by other iCarsoft (and I think Autel, too) users. It seems that these units always put the ESP unit into road test mode whenever it is scanned for codes. This is the procedure form SDS to complete the test:

 

·
Registered
1999 E320, 2000 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Joined
·
2,734 Posts
Is your car a coupe or convertible?
 

·
Registered
Joined
·
35 Posts
Discussion Starter #8
Coupe. And thats the proceedure i followed, and all lights and warnings cleared. Only to return upon restarting.
Those instructions are rather vague and non-specific. Do i need to do the whole test in the "10 s (seconds)" it states?
 

·
Registered
2008 AMG CLK63 Conv., 2012 R350 4-Matic, Wife's 2015 C300 sedan
Joined
·
10,476 Posts
I have this issue with my CLK63 and the R350 at the moment.

Going to pull out both ckocksprings, reset, try try try again.

Failing that off to the dealership. Grr..

B
Perhaps we should get together and send icarsoft a combined email or letter....
 

·
Registered
1999 E320, 2000 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Joined
·
2,734 Posts
This is a problem that has been reported several times by other iCarsoft (and I think Autel, too) users. It seems that these units always put the ESP unit into road test mode whenever it is scanned for codes.
Just a note: My Autel MD802 does NOT put ESP unit into road test mode. It just scans for codes and can erase them without any issues.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #11
I have written iCarsoft with situation and asking for info/guidance. No response, of course.
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
19,364 Posts
Just replace the word "cornering with "turning". What you do is start the engine, disable ESP with the dash switch, drive at about 6mph, and then turn the wheel (left or right - your choice) more than 90 degrees. Make a quarter of a circle, and then turn the wheel in the opposite direction and make that quarter-circle. Both quarter circles need to be done at about 6mph and both of them done within 10 seconds.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #13
Ok, THATS what the 10s meant. Thanks for the translation into english! I think thats what i dis wrong- i didnt want to rush the process, so i bet i took over 10 seconds.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #14
Next question- what the hell is a SQUIB? Ive been working on cars and motorcycles for over 30 years, and never heard of a squib. You you put coctail sause on your squib, or drawn butter? "Firing off a squib" sounds like a metaphor for SHART-ing.?
 

·
Registered
2016 GLE 400 4Matic
Joined
·
453 Posts
Next question- what the hell is a SQUIB? Ive been working on cars and motorcycles for over 30 years, and never heard of a squib. You you put coctail sause on your squib, or drawn butter? "Firing off a squib" sounds like a metaphor for SHART-ing.?
The squib is the component within the air bag inflator that begins the deployment process. If the squib is generating a DTC error code you must replace the airbag in question.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #16
Actually its a SRS warning, and light. "Left front side airbag ignition squib" has too high of resistance.
Also, what the difference (or is it obvious) between "stored" and "stored and current"? If just stored, does that mean condition corrected, one time fault, and current being... just that- current?
 

·
Registered
Joined
·
35 Posts
Discussion Starter #17
Ok, im about to lose it. Ive tried 2 more times to get out of roadtest mode, to no avail. Ive taken all suggestions, did it more rapidly (within 10 seconds), everything. And every time, the warnings clear, the ABS light goes out, all good... until i restart. Am i supposed to be hooked up to iCarsoft, then "end diagnosis, turn off ignition...? Am i supposed to turn off engine immediatly after all clearing? I cant figure out what im doing wrong! 6mph, turn to one side, more than 90° rotation of wheel, for atleast quarter circle, the turn back other way, again more than 90° from straight(180° total) for a quarter circle, all under 10 seconds. Then warnings and ABS light goes out. So why does it keep coming back on? I know i have an ESP item, and a SRS item to get resolved, but its flashing BAS (no idea what that is), and ABS, in addition to SRS and ESP, and all say (paraphrasing) "diagnosis in progress", or whatever. Before, i had ESP and SRS tell me to visit workshop, only.
I swear, if i had box it came in, id return that damn iCarsoft to Amazon!
 

·
Registered
Joined
·
35 Posts
Discussion Starter #18
Do i need to leave the MBII plugged in, or in road test mode on the MBII, in order to clear road test indicators? Then unplug after successful roadtest?
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
19,364 Posts
You don;t need the MBII plugged in during the road test.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #20
Then i am totally at a loss, as to why it successfully clears after roadtest, yet all comes back on, back into roadtest mode, upin restarting engine.
 
1 - 20 of 39 Posts
Top