Mercedes-Benz Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
so i got a CEL and my code reader says random misfire detected and cylinder number 3 misfire detected. I plug the plug and cleaned it and that didnt help. I switched coil packs and that didnt help. So now im tihnking injector? How would I go about doing this? It should be relatively simple yes? Thanks for all help! :) Cody
 

·
Registered
C230K Sport Sedan
Joined
·
5,368 Posts
You can swap injectors, no problem, never did it on my kid's SLK, but I'm sure it similar to other cars so these are generic instructions. Find the fuel rail and disconnected from the fuel line. Remove any bolts holding the fuel rail down. Disconnect any wires in the way and pull the rail away from the injectors, may take some effort, but most are held in with friction. Disconnect the harness from the injectors you want to swap, there's usually a clip you can pry with a screwdriver. Then pull out the injectors. They sell injector pullers for this purpose, just be careful not to damage it coming out if you want to reuse them. Lube the injector seals before putting it back together and take your time, it's not that hard, certainly not harder than plugs and coil packs, just different.

Maybe someone can post more SLK 230 specific instructions, maybe you can after doing it. Checking parts at parts.com, a genuine MB injector is $133 and new seals are $2.
 

·
Registered
2002 SLK 230 1986 560SL 2008 Honda CRV
Joined
·
3,664 Posts
Cleaning the plug may not be enough, the plug could be bad. Replace all the plugs first, check all connections to the coil packs, run some good injector cleaner through the system then see what happens.
 

·
Registered
08 ml320 cdi,slk 230,01 boxster S,04carrera911, 99 S320,67 GT350mustang,02G500L,96 s600 w140, e55 2k
Joined
·
1,697 Posts
any update?
 

·
Registered
126 85 300sd, 124 300e, 116 78 450 sel, 126C 85 500 sec, 02 g 500
Joined
·
7 Posts
Hey masters G500

I have replaced almost every possible part suggested here and still no luck (random shakes) lately i have some copm connected and it shows bad injector cyl2 , Car is 79 000 mils , Im suspecting the engine was over heated or close to (engine oil 16 000 mile over the change time) and it looks like tar . I m thinking of takeng all injectors out and sending them to service ?
 
1 - 7 of 7 Posts
Top