Mercedes-Benz Forum banner

1 - 20 of 96 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
hello my 1990 200e sometimes cuts out when driving mostly when just reaching running temp does not hapen everyday just now & then ?
also sometimes when its just reaching running temp if you turn off the engine then go to start it up it will not start leave it for about 2 mins then it will sart no problem this is an intermiting fault ?
i thort it was supermarket fuel so i only now use good fuel like esso or bp super unleaded this did stop the problems for a wile but its started to do it again can anybody help please
 

·
Registered
Joined
·
16,783 Posts
Check fuel system, starting with fuel pump relay, fuel pumps, EHA.

Also check fuel accumulator and replace fuel filter. Be sure to use new copper crush washers when replacing the filter to avoid a fuel leak.

Do a search to find out how to troubleshoot the KE-Jetronic fuel system.

I would recommend replacing the fuel filter & fuel accumulator and see if behavior changes. You might be dealing with old worn out fuel pumps. How many kms/miles on the car???
 

·
Registered
Joined
·
43 Posts
Discussion Starter #3
the car has just done 13000 miles family owned was my grandads & my dads before mine :)
i did the fuel filter last year i think:confused:
what it the fuel acumilator can you show me a pic of it & where on the car is it please:confused:
 

·
Registered
Joined
·
16,783 Posts
Only 13K miles on a 20+ year old car??? Maybe your issue could be fuel contamination due to the car sitting unused for extended periods?
 

·
Registered
Joined
·
43 Posts
Discussion Starter #8
the car gets used every day so i dont think in fuel contamination
the miles are 13000 miles not to bad for a 1990 car;)
 

·
Registered
Joined
·
16,783 Posts
the car gets used every day so i dont think in fuel contamination
the miles are 13000 miles not to bad for a 1990 car;)
:confused:Now I'm even more confused:confused:. Let's do the math here

13000 miles / 7665 days (21 years) = 1.696020874103066 miles driven each day??? Highly unlikely scenario, unless you live in a mansion/castle and you only use the car to drive up to the main gate to pick up the newspaper each day:D.

IF that is really the case, the car never even gets up to full operating temp which means you need to follow the severe duty maintenance schedule with the most frequent service intervals.

Also, if you really do drive that little that means you would only need to fuel up twice each year. Again, fuel contamination seems to be lurking around the bend if what you state is true.

You will likely be dealing with rusty exhaust components as well, again due to lack of proper warm up cycles and the engine never going into closed loop operation due to a O2 sensor which probably has never needed to work since the car left the factory.

BTW, the fuel accumulator is responsible for holding proper fuel pressure in the system. A hard start condition (i.e. requiring a 2nd start attempt) during hot/cold starts are indicative of a potential fuel accumulator problem. Pinch off the small hose coming off the accumulator and see if starting behavior changes. Replace as needed.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #11
130000 miles one hundred & thirty thousand miles :bowdown:
ive got a new fuel filter & fuel pump comming carnt get a fuel acumilator from nobody lists it any ideas :confused::help:
 

·
Registered
Joined
·
16,783 Posts
Try this link for the fuel accumulator, and use the p/n#s listed. You may be able to find it in the UK without having to pay overseas shipping fees for a part that is made in Europe anyway.

Febi 0004760621

Bosch 0438170035

Suggest you use the Bosch piece as they are the OES to MB. Test your fuel accumulator first by pinching off the small hose at the nipple end of the accumulator and observe for any change in starting behavior.

Also, check for the # of fuel pumps. It is very likely your car has 2 identical pumps. Replace them as a set if you are replacing pumps, and always use new copper crush washers at all banjo style fuel connections.
 

Attachments

·
Registered
Joined
·
43 Posts
Discussion Starter #13
i think mine has only 1 fuel pump
thanks for the info i will check the acumulator at the weekend
 

·
Registered
Joined
·
43 Posts
Discussion Starter #14
Try this link for the fuel accumulator, and use the p/n#s listed. You may be able to find it in the UK without having to pay overseas shipping fees for a part that is made in Europe anyway.

Febi 0004760621

Bosch 0438170035

Suggest you use the Bosch piece as they are the OES to MB. Test your fuel accumulator first by pinching off the small hose at the nipple end of the accumulator and observe for any change in starting behavior.

Also, check for the # of fuel pumps. It is very likely your car has 2 identical pumps. Replace them as a set if you are replacing pumps, and always use new copper crush washers at all banjo style fuel connections.
what link :confused:
 

·
Registered
Joined
·
16,783 Posts
Sorry, my mistake. I meant copy the p/n#s I posted and paste them into a search engine of your choice (Google, Bing, etc.).
 

·
Registered
Joined
·
43 Posts
Discussion Starter #16
hello all ive replaced the fuel filter with new washers & the fuel accumilator today all seems ok will see over the next week or so
i will let you all know if its fixed ths fault now ?
 

·
Registered
Joined
·
43 Posts
Discussion Starter #17
more cutting out problems

:crybaby2: more cutting out problems its just the same as before cutting out when just warming up & today it cut out when it was warm
i am getting fed up with this :mad:
ive replaced the fuel acumilator & fuel filter so what shall i do now
any ideas :bowdown:
 
1 - 20 of 96 Posts
Top