Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
1998 W210 E280
Joined
·
176 Posts
Discussion Starter #1
Hi all

  1. When to the store earlier, and while standing at the shop, car idling, park brake engaged, I pressed the cruise control button on the stork. ASR light came on, and revs jumped up to about 1500rpm. Almost as if it tried to get to the max speed set at 80kph. Tried to cancel the cruise control by pressing the button on the stork but that wouldn't disengage the cruise control.
Freaked me out so much I just switched off the ignition.

So im parked, handbrake engaged, brake lights work, tire size and pressure okay.

Any ideas as to what might cUse that issue?
 

·
Registered
1998 W210 E280
Joined
·
176 Posts
Discussion Starter #2
On my way back home I had no abs or asr lights or any other warnings come on. Everything back to normal again. Would still appreciate some advice
 

·
Registered
E320/E250 Bluetec Ford F350 6.7l
Joined
·
36,318 Posts
Mercedes makes lot of options for different countries and when I did not hear about such option on US W210, that sounds like high idle option. I hear about it on Sprinter vans, who use it for faster engine warming, or cabin cooling.
 

·
Registered
1998 W210 E280
Joined
·
176 Posts
Discussion Starter #4
Thanx man. Just a update, came back from a short drive and tried activating the CC while driving and it wouldn't activate at all. Light on the stork shows amber, but car does not maintain speed, instead it slows down. No warning lights at all. Stopped at a shop, switched off and started up again, and the revs shot up to 2000 rpm. Switched off again and all was normal. Confused
 

·
Premium Member
1998 E320 base sedan @ 160kmiles
Joined
·
6,186 Posts
If you have a problem with traction system, the cruise control will not work. You have some serious electrical issues with your car buddy.
 

·
Registered
1999 E320, 2003 E320 Wagon, 2005 C230K SS, 2010 Accord LX w Eibach & Koni FSD's
Joined
·
2,653 Posts
Just curious........can you post picture of your CC lever? Never seen or heard of the one you have.
 

·
Premium Member
1998 E320 base sedan @ 160kmiles
Joined
·
6,186 Posts
Thanx man. Just a update, came back from a short drive and tried activating the CC while driving and it wouldn't activate at all. Light on the stork shows amber, but car does not maintain speed, instead it slows down. No warning lights at all. Stopped at a shop, switched off and started up again, and the revs shot up to 2000 rpm. Switched off again and all was normal. Confused
Your car has speed limiter option, and the amber light on the stalk shows that the speed limiter is activated, NOT the cruise control. When the car reaches the desired set limit, a light on the instrument cluster will show up (that looks like a dial).
 

·
Registered
1998 W210 E280
Joined
·
176 Posts
Discussion Starter #8
Hi MrB

Sheew, almost had a stroke last night. And you are correct with the speed limiter. I was sitting in the car last night messing around with the stork and I saw the dash screen light up showing a 40kmph. Kept pressing it and watched the numbers go up until I reached the 3 dashed lines. Wasn't sure what that meant but kinda figured it meant that there was no limiter. Thanx for the explanation sir.

260e Cruiser, will upload a Pic when I get home this evening
 
1 - 8 of 8 Posts
Top