Mercedes-Benz Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
36,559 Posts
Discussion Starter · #1 ·
I did check and replace:OVP(10A red fuse);all brake light bulbs(still original);spark plugs+rotor+dist cap replace;voltage regulator brush replace(alternator)BUT cruise control(C/C)still not worked.Is anybody have same problem as my car ? Independent Mercedez shop estimate about $1500.00 to fix my car.Any suggestion are appreciated .Thanks
 

· Registered
Joined
·
36,559 Posts
Discussion Starter · #3 ·
Re: Cruise control drive me

Dude I have a 190D 2.2 and the cruise control has supposedly never worked. The guy I bought it from said it worked inconsistantly ever since it was off the lot. It has been in for cruise control fixes numerous times he tells me and it still didn't fix it. I don't feel like payin that much money to get it working. I know it doesn't work, I've tried using it many times.
 

· Registered
Joined
·
36,559 Posts
Discussion Starter · #7 ·
Re: Cruise control drive me

You said you repleced the brake light bulbs, but do they work? I ask because my cruise control was working only intermittently and then someone told me that I had a brake light out. The bulb was fine, but the spring contact in the bottom of the socket was not making good contact. I simply bent it up a little, very gently, and now the brake light works AND the cruise control functions perfectly. This may not be your problem, but it's a 5 minute, free fix, so worth checking out. Good luck.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top