Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
2002 CL55 AMG, 1993 190E 2.3L, 2004 SLK320 Sport
Joined
·
1,733 Posts
Discussion Starter #1
As I slow down from about 40km to stop, my speedo is jumpy. It goes up and down until it stops at 0!
Basically, it seems to be vibrating up and down! I think I also hear a squeking sound from behind the cluster! You think maybe time for a new speedo cable?

thanks, SPIROS
 

·
Registered
1990 W124 300TE-24 3.4 AMG, 1991 W126 300SEL
Joined
·
152 Posts
hyprr1 - 4/8/2005 9:47 PM

As I slow down from about 40km to stop, my speedo is jumpy. It goes up and down until it stops at 0!
Basically, it seems to be vibrating up and down! I think I also hear a squeking sound from behind the cluster! You think maybe time for a new speedo cable?

thanks, SPIROS
I had the same problem too but didn't have the time to change the speedometer cable so I pull the cluster unit out and disconnect the speedo cable. Smeared some grease at the end of the cable and connected it back again. The ticking noise now gone and it didn't vibrate as much as before.
 

·
Registered
E220 1994
Joined
·
72 Posts
Me too. The problem started at one instance that I push the rod when the car is moving. Someone said that this may damage the speedometer gears and resulted in a jumpy needle.
 

·
Registered
1987 Mercedes 300e
Joined
·
400 Posts
my speedometer doesn't go down when decelerating.. so if im going 40.. and i slow down without pressing the brakes down the 20 mph... it still says 40 mph... ideas?
 
1 - 6 of 6 Posts
Top