Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1999 S600 98K miles, 1994 E320 Cabriolet 13K, 2012 GLK 24K
Joined
·
239 Posts
Discussion Starter #1
While driving my 99 S600 today the radio kept cutting out and the antenna randomly is retracting although the mast seems to be tight not loose. This cutting out happens on am and cd play as well. First thoughts? There must be a switch that turns on when the antennna starts to rise - maybe a bad ground. How do I pull the left trunk lining away to take a look? I just drove 1700 flawless highway miles to Florida but want to have a working radio when I return. Thanks
 

·
Registered
1994 S600 Coupe, 1995 S600 Coupe
Joined
·
2,009 Posts
The antenna and amp get a signal to turn on from the headunit in the dash. So your problem could be there, or a power or ground problem in the trunk. Since the amp and antenna are next to each other, they probably share a common ground. Check that, and make sure the grounds are clean and tight. Look for a bunch of brown wires going to a common place on the body structure near the amp.

You'll have to remove the left side side wall carpet. If you have a CD changer, it needs to come out first.

Jon
 

·
Registered
1999 S600 98K miles, 1994 E320 Cabriolet 13K, 2012 GLK 24K
Joined
·
239 Posts
Discussion Starter #3
Thanks head unit always stays lit with display when on so thinking probably at antenna area and ground would explain erratic nature. I first noticed it last night when the antenna didn’t go down when I turned off the radio, turned it on and off again and it went down.
 
1 - 3 of 3 Posts
Top