Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2001 ML320
Joined
·
10 Posts
Discussion Starter #1
In December I purchased a 2001 ml320 with 75,000 miles not knowing what services had been done I replaced air, oil, fuel filters, plugs. it ran fine with an occasional flutter at idle and stall when cold. then...wednesday morning, no start, felt like no fuel, bought and installed a fuel pump, nope! installed a crank sensor and fired right up! I needed the pump awyway do to the incorrect fuel gauge readings. then it wouldn't sift out of park[:(!] researced and found the "pen" bypass, picking up the brake light switch later today I just wanted to thank all of you for the info on everything I would still be scratching my head as to were to start if I never found this site. I wish I didn't have to log on so often but in some sick way, I guess I kinda like this detective work on the car (I mentioned sick didn't I).
 

·
Registered
2011 GLK,2007 S550,2003 S55,2008 CLK,2009 C300,1996 E300,2005 E320,2002 E3
Joined
·
1,355 Posts
How is it running now? I hope all is well[8)]
 

·
Registered
2001 ML320
Joined
·
10 Posts
Discussion Starter #3
It ran just fine until this afternoon. It did the stumble right after start-up. I didn't give it much of a chance to warm up. If I shut it off and restart, it runs o.k. The occasional ruff idle is beginning to rear its ugly head again too. prior to all this work if it stumbled and i gave it more gas to get going the check engine light popped on and went off after a day or two. I'm thinking about O2 sensor replacement time. What are your thoughts
thanks,
Vince
 

·
Registered
2011 GLK,2007 S550,2003 S55,2008 CLK,2009 C300,1996 E300,2005 E320,2002 E3
Joined
·
1,355 Posts
Try to pull the fault code, it may possibly be related to your 02 sensor. When you get a chance Monday, contact your local dealer and have him run your VIN. He will be able to tell you all of the warranty work that was done on the ML. This may help lead you in the right direction, as to what has already been replaced while the vehicle was under its 4yr 50,000 warranty. I have seen some ML's that have been through several MAF sensors and 02 senors faster than others[8D]. Then of course replace the little cheap things on the way, like the fuel filter. I had a dirty filter give me fits on a Mercedes before.

Keep us posted,
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
19,255 Posts
Vince:

This is exactly the same problem I have always had with my 2001 ML320. It seems to be worse when the ambient temp is hot and the engine is cold. My guess is that any OBD codes that might be registered will be "misfire" codes, which do not help diagnose the problem. The best thing that was done to mine was to have the ECM replaced and some “experimental� code programmed into it. I have not had any backfires or complete stalls since that change, but I do sometimes still get a definite hesitation. If you ever get to a resolution, let me know (actually, MBZ themselves would like to know, too).

- RODNEY
 
1 - 5 of 5 Posts
Top