Mercedes-Benz Forum banner
Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
2002 S430V
Joined
·
85 Posts
Discussion Starter · #1 ·
Hello everyone,

I had installed my bluetooth telephone system into my 2002 S430V about a year or so ago and I sometimes have connectivity issues between the puck and cable. I have the puck secured in place with heavy duty mounting tape and the cable secured as well with the tape. I used to use velcro but it didn't hold the puck in place as well as the mounting tape. I have been reading the telephone write up that Skylaw had completed and was considering that maybe the cradle is a better option than the cradle eliminator cable. I was hoping to hear from users on the forum who have tried both and can say which one has provided better overall quality.
 

·
W221 & Audio Moderator
2013 S550
Joined
·
11,214 Posts
There are two cradles - a V60 and a slightly larger V60S. The V60 puck fits the V60S cradle better. The smaller V60 cradle sometimes has problems making proper contact.

Have you checked your connectors for dirt or crud? I haven't seen any problems reported with it, prior to this.

Also, I wonder if the tape you're using on the connector might be pulling it downward, breaking some contacts (a problem I had with an iPod installation with a USB cable in my wife's Lincoln)?
 

·
Registered
2003 S500
Joined
·
3,218 Posts
I have had connection problems between the cradle and the puck. I cleaned the contacts repeatedly, and applied Stabil (a very expensive and generally effective contact-enhancer), but the phone continued to fail randomly. Eventually (a few weeks ago) the little springy arm that locks the puck into the cradle broke.

I used some good-quality black electrical tape, stretched tightly length-wise over the two, to secure the puck into the cradle. The phone has worked very well since. I hope that the tape will prove to be a viable long-term repair...
 

·
Registered
2003 S500
Joined
·
3,218 Posts
I am not certain - there is no visible label on the puck or cradle and I am not willing to disassemble the pair, since it is now working.

Based upon what I have read in Skylaw's excellent info, it is most likely that I have the V-60 cradle and puck.
"If you have an ’03 or an ‘04 model with an OE phone installation, (except the ’03-’04 E Class and the ’04 S-Class) you are home free. You should already have the V60 “Autosense” PSE, and the V60 cradle."
 

·
Registered
2002 S430V
Joined
·
85 Posts
Discussion Starter · #6 ·
I went ahead and bought a V60S cradle to replace my cradle eliminator cable since I feel that it will be a better overall experience. However I need to find a template for when I drill the holes and am wondering if anyone can scan a template and send it to me or if they a know a source of a pdf version of the template so that I may print it out.
 

·
Registered
2002 S430V
Joined
·
85 Posts
Discussion Starter · #7 ·
I am going to start a new thread asking about the cradle template since my question for this thread has been answered.
 

·
Registered
2009 ML 350 4Matic, 2000 CLK 430
Joined
·
77 Posts
Hey all, curious on the Long term of your connection issues. Did the tape and securing of the puck correct the issue for good?
I have the v60 puck for many years now and still, no matter what I try (cradle
Eliminator, v60 (s) cradle , I’ll lose voice or sometimes people can’t hear me. I’ve tried cleaning connections many times - still an Intermittent issue.

Believe I narrowed the specific connectors causing the voice loss to the one’s towards the right end of the puck.
 

·
W220 Moderator
Joined
·
8,384 Posts
This thread is 8 years old and OP has not been seen since 2014 .......................................
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top