Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
1968 250S, 1974 280 CE, 1988 560 SEC, 1993 300SE, 2001 S430
Joined
·
63 Posts
Discussion Starter #1
Hi guys finally I start work with my car. I didn't mention car has leak from front of engine. I did 5 inspection with 5 diffident work shop. All workshop wants work on my car but they didn't give me any warranty is only small green gasket which is not part of head gasket so I decide remove head and do proper job. When I remove front part part of engine I find out loots oil under gasket but that was old oil not fresh. After removing head I found out head gasket don't have any crack or un-perfection but i find to very clean spot on block at corners. One spot front corner is same place where was loots of oil so that was a problem.

I spent more 2h under car to do inspection and I found Cracked insulation on lower harness loom. Cable is starting crack from Alternator (just thin green cable), cable from starter motor ( not all just all thin cable). I find out, all those cable + sensor is going together to right site of engine and going inside to car.

my question is where those cable going ??? How long there are how i can remove this loom and put new one.

another question what will be happen if i just do proper isolation of those crack cable or have to find new loom. I read people using Performix product

Liquid Electral Tape - Performix - 6oz CLEAR Spray | eBay

Im not sure but problem with cable is only where you have loots of heat so engine bay, so if i unscrew all connection and use those seal + thermal hose which you using with electrical parts to do extra cover.

Guys what you think that can help ???

Mario
 

·
Premium Member
84 500 SEL ...94 S420..... 95 S500.... 96 S500 95 S600
Joined
·
1,707 Posts
Hi guys finally I start work with my car. I didn't mention car has leak from front of engine. I did 5 inspection with 5 diffident work shop. All workshop wants work on my car but they didn't give me any warranty is only small green gasket which is not part of head gasket so I decide remove head and do proper job. When I remove front part part of engine I find out loots oil under gasket but that was old oil not fresh. After removing head I found out head gasket don't have any crack or un-perfection but i find to very clean spot on block at corners. One spot front corner is same place where was loots of oil so that was a problem.

I spent more 2h under car to do inspection and I found Cracked insulation on lower harness loom. Cable is starting crack from Alternator (just thin green cable), cable from starter motor ( not all just all thin cable). I find out, all those cable + sensor is going together to right site of engine and going inside to car.

my question is where those cable going ??? How long there are how i can remove this loom and put new one.

another question what will be happen if i just do proper isolation of those crack cable or have to find new loom. I read people using Performix product

Liquid Electral Tape - Performix - 6oz CLEAR Spray | eBay

Im not sure but problem with cable is only where you have loots of heat so engine bay, so if i unscrew all connection and use those seal + thermal hose which you using with electrical parts to do extra cover.

Guys what you think that can help ???

Mario
Mario, Go and buy a new lower positive cable at the dealer, they are not to expensive and install it. Its not a huge deal to install. The connection at one end is a round turn style locking plug just like the MAF sensor which is located under passenger side floor boards under the car. The other end connects the oil preasure sensor, alternator, starter etc. I paid $130.00 which is a wholesale price, list isnt that much more...good luck!! :)
 

·
W140 Moderator
"CHRIS" Merc 92 600SEL / Sold > 93 600SE / 93 S500 / 89 560SEL / 413CDI / B180-CDI /A170-CDI
Joined
·
7,639 Posts
You need a new lower engine harness (what is it this month ,you must be the 4th or 5th one ) , i know you 're up in Melbourne so dont waste your time ringing Mercedes Spare parts , they charge over a 1000 dollars for that harness ,shop around overseas auctions or try Eddie's solution above .
You too take a good look here ,page 1 reveals the aussie price ,make sure you sit down ,lol.:thumbsup:
http://www.benzworld.org/forums/w140-s-class/1589355-lower-engine-wiring-harness-v8-s500-3.html
 

·
Registered
2003 S55 AMG Kompressor
Joined
·
361 Posts
Or fix it yourself, very easy to be done if you can do electrical work, cost close to nothing. I did mine and it looks exactly like factory
 
1 - 4 of 4 Posts
Top