Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
2000 ML320
Joined
·
106 Posts
Discussion Starter #1
My 2000 ML320 is going through my coolant like there's no tomorrow. I took it in to the dealer because my coolant light kept coming on even after I had filled it. I was constantly topping off the thing. Turns out, I needed to replace my radiator, so I did that. I took it in last month because the coolant light came on again, they found no problems. Yesterday the coolant light came on freaking AGAIN! I checked the reservoir and found I was low on coolant, so I topped it off, but that's a little strange, don't ya think?


The second time the coolant light came on,I also had my oil light come on (could I possibly have any more warnings come up?!) - the dealer said there was no problem with the oil.

I don't think you can blame that on faulty sensors when I was actually low on coolant. When I checked my oil, the dipstick showed it was low. So my car says there's a problem, I can see a problem, but my dealer says everythings ok. WTF is happening?
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
19,241 Posts
My guess is that you have a blown head gasket. It sounds like coolant is leaking into the combustion chamber. See if you have any white vapor coming out after the engine is up to operating temp or if you smell antifreeze at the tailpipe. This could also cause coolant to be leaking into the oil, or oil entering the combustion chamber causing the oil light to illuminate.

- RODNEY
 

·
Registered
99ML320 (retired) C230 530xi 911-C4
Joined
·
2,229 Posts
rudeney - 5/10/2005 6:25 PM

My guess is that you have a blown head gasket. It sounds like coolant is leaking into the combustion chamber. See if you have any white vapor coming out after the engine is up to operating temp or if you smell antifreeze at the tailpipe. This could also cause coolant to be leaking into the oil, or oil entering the combustion chamber causing the oil light to illuminate.

- RODNEY
Rodney's right. I don't think there was anything wrong with the radiator to begin with.

Complain to service manager
 

·
Registered
2014 ML350 BlueTec
Joined
·
2,626 Posts
l know this is silly....but did you have that recall done on your vehicle ..the one with the lower rad hose and clamp.....My coolant light came on...they did a pressure test..they found out, l wasn't sustaining enough pressure, and they did the recall, no light ever since...
The Work order goes like this....

Oil leak from Powersteering at Radiator: Cause Recall.
023902 : Hose Clamp & Lower Power Steering Hose.
1 - 163-460-53-24-05 P/S Repair kit.
1 - 000-989-88-03 ST.Fluid 1/2 Litre.

Hope that helps....sounds exactly like my situation..
 
1 - 4 of 4 Posts
Top