Mercedes-Benz Forum banner

Coolant light

1177 Views 2 Replies 2 Participants Last post by  dellwas
Hi all,

The coolant light came on this morning on the way to work. It was not consistant (once for 5 minutes, couple of times for 30 secs or so). Coolant is up and can't see any leaks. There is also no signs of a head gasket leak (oil or coolant mixing)

I know some models (SLK?) have a coolant sensor and windshield washer wired in series, and if one goes the other can light up. Think this is the case?

I don't have a manual yet so any info. is greatly appreciated.
1 - 3 of 3 Posts

· BenzWorld W126 & W201 Host
1988 420SE, 2002 C180 Kompressor, 200 ML320
Joined
·
1,150 Posts
dellwas

More likely to be a faulty sensor. They are quite easy(only held in with a circlip) to replace and not too expensive.
 

· Registered
190 E
Joined
·
7 Posts
Discussion Starter · #3 ·
Actually I have a small coolant leak. I checked, it's not the head or the block. Ditto on the water pump. I pulled the "skid plate" and there was a small amount on top of it up near the bumper, right under the rad. I ran it for about 15 minutes and the bottom of the rad is bone dry. No leaks in the hoses. I suspect a small pin hole in the rad as there was a little coolant at the base of the fins. I'll try rad seal while I look for a rad replacement.


dellwas

More likely to be a faulty sensor. They are quite easy(only held in with a circlip) to replace and not too expensive.
[|)]
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top