Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
SL 550 2007, Previous: E55 AMG 2000, 450 SE 1979, 500 SL 1992, SL500 1998
Joined
·
341 Posts
Discussion Starter #1
the coolant level low light on my 1992 500 SL sometimes comes on when accelerating hard for a prolonged time when already running at high speeds. The coolant level is fine/unchanged. Still it lights up. Anyone recognise this or have a clue as to what is the problem?

Thanks
 

·
Registered
97SL500R129, 01ML320W163, 94E320W124 & 93500EW124
Joined
·
2,921 Posts
Coolant moves (shakes/splash) during acceleration or hard stops. This cause the level sensor float to move and create and open circuit which turn on the low coolant level light. Check for level sensor loose connection or replace/clean the sensor.
 

·
Registered
SL 550 2007, Previous: E55 AMG 2000, 450 SE 1979, 500 SL 1992, SL500 1998
Joined
·
341 Posts
Discussion Starter #3
Coolant moves (shakes/splash) during acceleration or hard stops. This cause the level sensor float to move and create and open circuit which turn on the low coolant level light. Check for level sensor loose connection or replace/clean the sensor.
Thanks, I will have a look at it .
 

·
Registered
94 SL600, 89 Jag XJS conv, 85 Daimler Princess, 97 993 63 Avanti 16 Lincoln MKZ hybrid 16 Silverado
Joined
·
720 Posts
Be green! sloooowly accelerate,
Never mind, I wouldn't take my advise, punch that sucker! You didn't buy it to be yard art, did ya?
 

·
Greek God of the R129
SL500-500SEL-190E
Joined
·
8,391 Posts
the coolant level low light on my 1992 500 SL sometimes comes on when accelerating hard for a prolonged time when already running at high speeds. The coolant level is fine/unchanged. Still it lights up. Anyone recognise this or have a clue as to what is the problem?

Thanks

I think that you are a little LOW.
Check it with engine COLD, it should be on the reservoir MARK.

Regards,
aam.
 
1 - 5 of 5 Posts
Top