Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
1987 560SL - 1994 S420 - 2005 S55 AMG
Joined
·
341 Posts
Discussion Starter #1
1994 S420 with 250K miles. Car has all new hoses installed. I still have a coolant leak that seems to only leak as the car is cooling down. It does not leak when the car is hot, however after several hours of sitting, a pint or more of coolant will leak out under the front center of the car's engine, and seems to come from where the lower radiator hose attaches to engine block.
By morning the car stops leaking. I ordered and installed upper radiator hose, lower radiator hose, short elbow hose at water pump, and coolant reservoir expansion hose yesterday, and leak continues. Coolant Light comes on and stays light until I top off coolant, so it is not A/C condensation.

Thanks
 

·
Registered
current fleet: 1996 s500; 1997 BMW 328ic; 2000 Nissan Frontier; 1966 AC Cobra
Joined
·
279 Posts
It may not be a hose problem, could be your water pump. Since it is not leaking when hot, device expansion is sealing the system, since it is hot it is also under pressure.

When it cools, something contracts, and thus it leaks.

Suggest a pressure test to spot the leak (with the sytem cold)
 

·
Registered
1989 190e 2.6 1993 500sel (sold) 1995 S500 coupe (sold) 1994 S500 blk/blk
Joined
·
1,007 Posts
This symptom is also presented when the expansion tank cap is fatigued, or it is the wrong one for your system.
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,633 Posts
There is a pressure-bleed hole in the water pump that protects the bearing, when the internal seal fails it will start to leak from there.

Take care and enjoy the ride,
Greg
 

·
Registered
1987 560SL - 1994 S420 - 2005 S55 AMG
Joined
·
341 Posts
Discussion Starter #6
I have a new expansion tank cap. Car did not leak first day, however the leak reappeared the second day after sitting for 8 hours. It appears to drip somewhere just behind the lower radiator hose where it connects under the engine. Is there a hose back there that is not visible? I'll put it on the lift this Thursday and hopefully spot the problem.
 
1 - 6 of 6 Posts
Top