Mercedes-Benz Forum banner

21 - 29 of 29 Posts

·
Outstanding Contributor
'85 300D Turbo, '91 420SEL, '92 190E 2.6, '09 C350, '12 E63 Wagon
Joined
·
3,164 Posts
Here's how it looks. I guess it was the lower hose! Sorry about the mix-up!!!

The belt is gator-back style. (I liked the concept...)
 

·
W201 Moderator
89 190E2.6- 5-speed Manual, 95 E320 Sportsline-sold, 2001 E320 4matic Wagon-sold
Joined
·
2,614 Posts
It's a fairly new one. I replaced it last summer after I replaced the water pump.
I could test with the old one, if I can find it. There was nothing wrong with the old one... I think. I will have to look.
I would definitely check that. The problem coincides with the replacement it looks like. New cap could be defective.
Unlikely but worth checking into.
 

·
Moderator
190E, SLK350
Joined
·
67,005 Posts
Discussion Starter #23
This problem has gotten worse.
I can't find a metal thermostat housing online with the upper piece (banjo I believe) that connects back to the coolant reservoir.
 

·
Outstanding Contributor
'85 300D Turbo, '91 420SEL, '92 190E 2.6, '09 C350, '12 E63 Wagon
Joined
·
3,164 Posts
Check ECS Tuning for a good price:

1022030374

Sent from my moto g(7) power using Tapatalk
 

·
Moderator
190E, SLK350
Joined
·
67,005 Posts
Discussion Starter #26
I replaced the thermostat, housing and upper hose. Car leaked after sitting overnight :(
It leaked right around the hose and thermostat housing. I believe I tightened the clamp well enough....
 

·
W201 Moderator
89 190E2.6- 5-speed Manual, 95 E320 Sportsline-sold, 2001 E320 4matic Wagon-sold
Joined
·
2,614 Posts
Is your radiator cap working properly? Any chance the system builds up too much pressure?
I think the cap is supposed the let excess pressure get released to the bag in the wheel well.
I could be wrong but that is what I thought.
 

·
Outstanding Contributor
'85 300D Turbo, '91 420SEL, '92 190E 2.6, '09 C350, '12 E63 Wagon
Joined
·
3,164 Posts
Post a pic/pics of the leak...

Sent from my moto g(7) power using Tapatalk
 

·
Moderator
190E, SLK350
Joined
·
67,005 Posts
Discussion Starter #29
I installed a new radiator cap. Let's see how it goes.
By the way, I tried to look for new upper hose clamps but I couldn't find anything made by Mercedes.
 
21 - 29 of 29 Posts
Top