Mercedes-Benz Forum banner

1 - 18 of 18 Posts

·
Registered
1995 BMW 530i, 1990 Mercedes-Benz 500SL, 2002 Ford Explorer EB V8 4x4
Joined
·
81 Posts
Discussion Starter #1
Hi Guys,

My Convertible Roof Switch is intermittently flashing. It never used to bother me until all of a sudden a strange gong noise appeared today while it flashes.

It will be solid light when stopped/brake applied, then flashing once the car is in motion.

I tried opening and closing the front and rear latches, and it latches fine. When I press the switch forward once or twice, everything will be normal, and the switch will no longer illuminate, and no gong present. Then maybe after a bump or 3-5 minutes it will re-appear.

Does this sound like any sensor defect?

Thanks in advance.
 

·
Registered
1997 SL-500; 2002 ML 500 sold; 1999 ML 320 sold; 2003 E 500 Sport sold
Joined
·
235 Posts
Try pressing down on each of the rear corners of the top, if the light goes out it may be a latch needs adjustment to draw the top down tighter. I had to put shims in my hardtop rear fingers to eliminate this light.
 

·
Registered
1995 BMW 530i, 1990 Mercedes-Benz 500SL, 2002 Ford Explorer EB V8 4x4
Joined
·
81 Posts
Discussion Starter #3
Try pressing down on each of the rear corners of the top, if the light goes out it may be a latch needs adjustment to draw the top down tighter. I had to put shims in my hardtop rear fingers to eliminate this light.
thanks for the tip! i'll have to try pressing down on the latches later.

This is the soft top on, but I may just switch to the hard top soon.

Does anyone know where the location of the gong (warning sound) is? I just want the sound to stop.
 

·
Registered
2005 SLK350, 91 300SL with Pano Top, 04 S500, 2015 Tesla Model S
Joined
·
2,078 Posts
The flashing and sound mean that it is not properly latched. Do as suggested and press down. Getting rid of the sound is like removing an instrument bulb to hide a problem.
 

·
Administrator
1998 Pano SL500; 1993 SL500; 2005 ML270cdi
Joined
·
8,728 Posts
The early R129s also used the red soft top switch as code flasher!!!

Count the flashes and check the codes against your year and model, this may give you the answer to your problems/s :thumbsup:
 

·
Registered
2005 SLK350, 91 300SL with Pano Top, 04 S500, 2015 Tesla Model S
Joined
·
2,078 Posts
I had this happening to my hard top. Passenger side rear latch did not lock properly. Even pressing on it would not help. I did not want to adjust the latch itself because it worked flawlessly with the soft top. Adding a 1/8" shim to the hard top latch finger mount solved the problem. You can get the proper shim from the stealer but I just used two washers.
 

·
Registered
1995 BMW 530i, 1990 Mercedes-Benz 500SL, 2002 Ford Explorer EB V8 4x4
Joined
·
81 Posts
Discussion Starter #7
The early R129s also used the red soft top switch as code flasher!!!

Count the flashes and check the codes against your year and model, this may give you the answer to your problems/s :thumbsup:
in what position should you do a code read? key on position 2 only or something specific?

the light is solid when stopped, and flashing when the car is in motion constantly. There is no sequence for me to read a code.

Thanks
 

·
Administrator
1998 Pano SL500; 1993 SL500; 2005 ML270cdi
Joined
·
8,728 Posts
in what position should you do a code read? key on position 2 only or something specific?

the light is solid when stopped, and flashing when the car is in motion constantly. There is no sequence for me to read a code.

Thanks
If it is constantly flashing then there is a problem.
As mentioned it could be the latches.
If Klaus from TopHydraulics picks up this thread, I'm sure he will have some very good advice.
 

·
Greek God of the R129
SL500-500SEL-190E
Joined
·
8,371 Posts
James,
I think a few years back Bob Terry may have mentioned the how... on reading the codes from the top light
It is a looong time, I don't remember how is done.
Should be in the files somewhere.
Could be key on two & holding the top button down????

Regards,
aam.
 

·
Premium Member
2015 Jaguar XF R Sport Twin Turbo, 1992 500sl Pano, 1999 CBR 1100XX, Super BlackBird, Jaguar X Type
Joined
·
4,818 Posts
From one of my earlier posts, hope this helps. Worked for me. (16 pin)



2, The RST codes on your model can be checked by using the console switch that puts the soft top up and down. No l.e.d is needed for this, the procedure with ign switch in position 2, is to put a paper clip between socket 10 and 1 hold for 3 sec and remove. The light in the console switch will flash the codes, when you have repeated this procedure enough times to obtain all the codes and come back to your first code you can start deleting the codes. This is achieved by holding the paper clip between socket 1 and 10 for 8+seconds then repeating the procedure until all the codes are erased. It may be necessary to repeat the procedure if some codes dont erase the first time. Eventually coming down to 1 blink everything A ok
Don't be fazed by the amount of codes you have showing on pin 10 I had the same and there is nothing wrong with my RST, I am of the opinion that not all codes stored are fault codes but some may stay if it's function is not in use at that specific time.

3, The same applies with the Roll bar, with the ign switch in position 2 and all the dash board features lit. the light with the rollbar display (this is the light in the dash and not the switch on the console) will flash it's codes
if you follow the same procedures as above between pins 1 and 7 to read and delete until you get back to one blink.

It will help if you get the wife sat in the drivers seat to count the flashes.

2 very important things to remember 1/ give her pen and paper or she will forget how many flashes and 2/ do not use a plastic paper clip
 

·
Greek God of the R129
SL500-500SEL-190E
Joined
·
8,371 Posts
Poundy,
Thanks for clarifying that.

1. You need a wife.

No wife to count?
No problem.

2. Maybe if you are fast on the legs/looking from the windshield.

3. Place strategically a mirror.

There are many ways to skin a cat. Lol.

Regards,
aam.
 

·
Premium Member
2012 E350 - 1994 SL600
Joined
·
935 Posts
The instructions, if I read them correctly just said "the wife", it doesn't have to be your wife.
 

·
Premium Member
2015 Jaguar XF R Sport Twin Turbo, 1992 500sl Pano, 1999 CBR 1100XX, Super BlackBird, Jaguar X Type
Joined
·
4,818 Posts
1, It is best to use your wife, she will probably put up with the mood swing when everything goes pear shaped.

2, The girlfriend will probably tell you to sling your hook

3, You can use a male if you can find a good one. My daughter tells me the nice ones are all married or gay.

4, Do not use a cop or a crook, they will both leave you in a rush when the lights flash.
 

·
Registered
1995 BMW 530i, 1990 Mercedes-Benz 500SL, 2002 Ford Explorer EB V8 4x4
Joined
·
81 Posts
Discussion Starter #14
thanks for the step-by-step code reading instructions. I'll try to get to it at some point.

I found out that the gong was coming from a speaker in the dome light assembly. I ended up disconnecting it for the time being as it was driving me insane. I'll probably take the car to a specialist at some point later. At the mean time it is my DD, so I need to keep it crusing.
 

·
Registered
Joined
·
2 Posts
let my top down to check front cylinders above windshield i just looked at them after putting everything back raise the top one side latched the other wont then switch started flashing rollbar wont move and no pump sound did the window resync ?
 

·
Registered
Joined
·
2 Posts
2001 sl 500 we talked yesterday t did the over night reset by dis connecting neg side of battery my roll bar is working again the hard top is not unlatching but it sounds like it trying in the back the red light is flashing with button pulled back with button pushed forward i hear a latch or something but on the window sync not sure if you do both windows at the same time but window go down a little we doors open all doors were shut trunk closed key switch #2 position then pulled red button back and held it 8 sec a couple of times not sure if i should manual unlock hard top and pull soft top up a couple of cycles
 

·
Registered
Joined
·
2 Posts
if the windows go down a little when you open the doors, then your windows are properly synchronized.

I'm afraid you will have to take the hard top off manually. The dealers will tell you that you cannot do it on a model year '01, but you can do it yourself and save hundreds of Dollars. There is a bit of work involved in removing the hard top manually and then finding the reason for the malfunction, but I think you should give it a try. Please check out the photos at the end of the following instructions for manual unlocking in the rear: http://www.tophydraulicsinc.com/maunuallockhardtop.pdf

After the hard top is off, you will have to pull up the rear locks to the fully open position; see http://www.benzworld.org/forums/r129-sl-class/1608418-soft-top-hydraulics-totally-dead-i.h tml.

After that, you may have to raise the soft top manually. (Open the tonneau cover with the soft top tool if needed; see page 2 of http://www.tophydraulicsinc.com/R129 Tonneau Cover Lock Cylinders.pdf)

The top might work again after you manually lock the soft top in the front. If it will not work at that point, you will have to inspect the magnetic sensor in the middle of the windshield header. See the photo on top of page 3 in the following instructions (they may take a while to load - it's a large, high resolution file): http://www.tophydraulicsinc.com/R129 Front Locking Cylinder Removal.pdf. Is the sensor at the end of the brown and blue wires exactly in place as shown?

Sincerely,

Klaus Witte

Top Hydraulics, Inc.
90730 Southview Lane
Florence, OR 97439

(541) 902 3214
 

·
Registered
03 SL Kleemann, 97 SL320, 95 E320 cab, Tesla X, Ferrari 360, etc
Joined
·
949 Posts
2001 sl 500 we talked yesterday t did the over night reset by dis connecting neg side of battery my roll bar is working again the hard top is not unlatching but it sounds like it trying in the back the red light is flashing with button pulled back with button pushed forward i hear a latch or something but on the window sync not sure if you do both windows at the same time but window go down a little we doors open all doors were shut trunk closed key switch #2 position then pulled red button back and held it 8 sec a couple of times not sure if i should manual unlock hard top and pull soft top up a couple of cycles
jrbaugh,

welcome to the forum!

If the windows go down a little when you open the doors, then your windows are properly synchronized.

I'm afraid you will have to take the hard top off manually. The dealers will tell you that you cannot do it on a model year '01, but you can do it yourself and save hundreds of Dollars. There is a bit of work involved in removing the hard top manually and then finding the reason for the malfunction, but I think you should give it a try. Please check out the photos at the end of the following instructions for manual unlocking in the rear: http://www.tophydraulicsinc.com/maunuallockhardtop.pdf

After the hard top is off, I suspect that you will find one rear lock not fully open. You will have to pull up the rear locks to the fully open position; see http://www.benzworld.org/forums/r129-sl-class/1608418-soft-top-hydraulics-totally-dead-i.html.

After that, you may have to raise the soft top manually, in order to get the controller out of its confused state. (Open the tonneau cover with the soft top tool if needed; see page 2 of http://www.tophydraulicsinc.com/R129 Tonneau Cover Lock Cylinders.pdf)

The top might work again after you manually lock the soft top in the front. If it will not work at that point, we will take it from there. Please let us know what you find...

Klaus

Top Hydraulics | Rebuilt Convertible Top Hydraulic Cylinders - Top Hydraulics, Inc
 
1 - 18 of 18 Posts
Top