Mercedes-Benz Forum banner

1 - 15 of 15 Posts

·
Registered
1998 SL500 Black on black
Joined
·
14 Posts
Discussion Starter #1
Hi all. I am new to the world of Mercedes. I’ve always wanted an SL500 and picked one up for a crazy steal!

After a couple tries, the hard top unlatched and I was able to remove it. My fathers raised the soft top which slowly engaged into the closed covered position and locked into place. Then we tried to make it go up and nothing! The roll bar also does not function anymore. I do hear clicking in the roll bar and the hydraulic motor.

After no luck we decided to manually putting the soft top back and hardtop back on. But the rear latches are stuck in a down position. We were able to manually raise the locks on each side with a screwdriver and lifting the rear unlatch knob in the trunk. Then we jammed a screw driver into the other end so the latch won’t fall shut and just closed the rear soft top back into place.

very confused and all of my extensive research I haven’t found an answer.
The red button allows me to open and close both windows but no luck with any soft top or convertible movement.
Rear rank is full of fluid. There is a little residue under it from a minor leak.

we’re so stumped! We’re unsure how to get the hardtop back on for the winter. It’s be nice to get everything working!
 

·
Registered
94 SL320 98 SL500 99 SL600
Joined
·
944 Posts
Disconnect the battery for 10 mins, re connect and cycle the windows to start with. Also keep in mind engine can't be running when dealing with the hard top. Is the red light on when either top is up or down?
 

·
Registered
1999 E320 4matic wagon 180k, 1998 SL500 80k, 2006 ML500 , 2009 ML350
Joined
·
52 Posts
Disconnect the battery for 10 mins, re connect and cycle the windows to start with. Also keep in mind engine can't be running when dealing with the hard top. Is the red light on when either top is up or down?
Hi all. I am new to the world of Mercedes. I’ve always wanted an SL500 and picked one up for a crazy steal!

After a couple tries, the hard top unlatched and I was able to remove it. My fathers raised the soft top which slowly engaged into the closed covered position and locked into place. Then we tried to make it go up and nothing! The roll bar also does not function anymore. I do hear clicking in the roll bar and the hydraulic motor.

After no luck we decided to manually putting the soft top back and hardtop back on. But the rear latches are stuck in a down position. We were able to manually raise the locks on each side with a screwdriver and lifting the rear unlatch knob in the trunk. Then we jammed a screw driver into the other end so the latch won’t fall shut and just closed the rear soft top back into place.

very confused and all of my extensive research I haven’t found an answer.
The red button allows me to open and close both windows but no luck with any soft top or convertible movement.
Rear rank is full of fluid. There is a little residue under it from a minor leak.

we’re so stumped! We’re unsure how to get the hardtop back on for the winter. It’s be nice to get everything working!
Make sure your battery is fully charged . A big mistake new owners make is starting to raise or lower the convertible top with a weak battery. Current on the system will go rise and blow the controller board.
What year is your car? I know you just bought it. Did the previous owner state when the last time the controller raised or lowered the top?
With a strong battery raise the windows and lower them ... keep the position at top and bottom for 10 seconds. Important question.... with the windows up.. when you open the door to the windows drop a 1/4” or so????
 

·
Registered
1998 SL500 Black on black
Joined
·
14 Posts
Discussion Starter #4
Disconnect the battery for 10 mins, re connect and cycle the windows to start with. Also keep in mind engine can't be running when dealing with the hard top. Is the red light on when either top is up or down?
I will make sure to try that when I manually put the hard top back on today. At the moment, the red light is off. But when I drive off, I get the 10 second chiming noise and flashing red button.

If I do have to put the hard top back on, i'll have to manually release the latched and push it up with a screw driver and hold it in place some how.
 

·
Registered
1998 SL500 Black on black
Joined
·
14 Posts
Discussion Starter #5
Make sure your battery is fully charged . A big mistake new owners make is starting to raise or lower the convertible top with a weak battery. Current on the system will go rise and blow the controller board.
What year is your car? I know you just bought it. Did the previous owner state when the last time the controller raised or lowered the top?
With a strong battery raise the windows and lower them ... keep the position at top and bottom for 10 seconds. Important question.... with the windows up.. when you open the door to the windows drop a 1/4” or so????

Thank you for the reply. The top was slow to raise and lower into closed position when we got it to work the one time.

The year is 1998. The owner actually knocked off a huge chunk of the price because he could not get the hard top to unlatch. Luckily it worked for us when we brought it home but this was the only time we got it to work and haven't tried it again since the soft top is stuck. I will go have the battery checked today, it does take a bit for the car to fire up when I turn the key. The windows do drop and raise when I open and close the doors.
 

·
Registered
1999 E320 4matic wagon 180k, 1998 SL500 80k, 2006 ML500 , 2009 ML350
Joined
·
52 Posts
Thank you for the reply. The top was slow to raise and lower into closed position when we got it to work the one time.

The year is 1998. The owner actually knocked off a huge chunk of the price because he could not get the hard top to unlatch. Luckily it worked for us when we brought it home but this was the only time we got it to work and haven't tried it again since the soft top is stuck. I will go have the battery checked today, it does take a bit for the car to fire up when I turn the key. The windows do drop and raise when I open and close the doors.
Ok it sounds like the controller is at least partially alive and possible ok.
You no doubt knocked everything out of sync . Start over with the top completely locked in the up position.
 

·
Registered
1998 SL500 Black on black
Joined
·
14 Posts
Discussion Starter #7
Ok it sounds like the controller is at least partially alive and possible ok.
You no doubt knocked everything out of sync . Start over with the top completely locked in the up position.
That is good to know. All of the 4 latches are locking the soft top in place, from what I assume, but the beeping noise when driving a few hundred feet and the red button flashes. We've tried many times to make the top go down. But the windows just roll down and once they are down, nothing happens after. I do hear clicking or something trying to engage. Same goes for trying to move the roll bar up. Just hear a click.
 

·
Registered
1999 E320 4matic wagon 180k, 1998 SL500 80k, 2006 ML500 , 2009 ML350
Joined
·
52 Posts
If the chiming goes out with the hardtop but it flashes and chimes with the soft top ... the front latch limit switches need adjustment or the latch arms on the soft top need adjusted. Look at the hard top latch arms and compared to the soft top. Sounds complicated but it really is easy. My Star system has a very nice feature showing the latches and limit switches. Still can take a little time but the Star system helps me clear out old error codes.
How is the system for leaks? Don’t forget when you are all done to change the fluid and put all new fluid in .
 

·
Registered
1998 SL500 Black on black
Joined
·
14 Posts
Discussion Starter #9
If the chiming goes out with the hardtop but it flashes and chimes with the soft top ... the front latch limit switches need adjustment or the latch arms on the soft top need adjusted. Look at the hard top latch arms and compared to the soft top. Sounds complicated but it really is easy. My Star system has a very nice feature showing the latches and limit switches. Still can take a little time but the Star system helps me clear out old error codes.
How is the system for leaks? Don’t forget when you are all done to change the fluid and put all new fluid in .
Thanks for the tip. Just an update, I replaced the battery as it had a low charge.

I played with the front latches. I unlatched both front manually, rolled the windows down and it would not let me roll them back up until I locked them back into place. My assumption is that the rear latches are not functioning correctly. When the car power is on 2, the red light stays on and turns off if I push forward, which brings the windows up if down, if theyre up it just makes a noise, and when pulling back on the red button, the windows roll all the way down then nothing.


I feel like the system is out of sync or something with the rear latches. My dad and I tried stowing away the soft top manually and had a lot of trouble right to get the metal lever inside the oval to go up even when moving the unlatch knob in the trunk. When the oval latch was moving, it was moving against the hydraulic pressure. If I lost grip, it just fell and clicked into a closed position until lifting it up again manually. It would never stay up.
 

·
Registered
1999 E320 4matic wagon 180k, 1998 SL500 80k, 2006 ML500 , 2009 ML350
Joined
·
52 Posts
A Mercedes Star system would tell
You quickly where the error is coming from . Tell me again which top gives NO ERRORS? Hardtop?
 

·
Registered
2000 SL500
Joined
·
352 Posts
Thanks for the tip. Just an update, I replaced the battery as it had a low charge.

I played with the front latches. I unlatched both front manually, rolled the windows down and it would not let me roll them back up until I locked them back into place. My assumption is that the rear latches are not functioning correctly. When the car power is on 2, the red light stays on and turns off if I push forward, which brings the windows up if down, if theyre up it just makes a noise, and when pulling back on the red button, the windows roll all the way down then nothing.


I feel like the system is out of sync or something with the rear latches. My dad and I tried stowing away the soft top manually and had a lot of trouble right to get the metal lever inside the oval to go up even when moving the unlatch knob in the trunk. When the oval latch was moving, it was moving against the hydraulic pressure. If I lost grip, it just fell and clicked into a closed position until lifting it up again manually. It would never stay up.
See pages 6 and 7 on manually opening the rear locks. If you're only pulling up on the latch through the top opening where the latch pin enters then you won't be able to engage the rear locks mechanical catch in the fully up position. You must push up from underneath the rod end or other locations shown in the photos. There's a mechanical pawl that engages and prevents the opened lock from sinking back down to the closed position. Be careful not to dislodge a spring that's on the side of the lock or you will cause yourself other problems, see page 8.

 

·
Registered
1998 SL500 Black on black
Joined
·
14 Posts
Discussion Starter #12
See pages 6 and 7 on manually opening the rear locks. If you're only pulling up on the latch through the top opening where the latch pin enters then you won't be able to engage the rear locks mechanical catch in the fully up position. You must push up from underneath the rod end or other locations shown in the photos. There's a mechanical pawl that engages and prevents the opened lock from sinking back down to the closed position. Be careful not to dislodge a spring that's on the side of the lock or you will cause yourself other problems, see page 8.

Thank you! This diagram is very helpfully. A bit confusing but I’ll spend time tomorrow comprehend everything it states.
So this will help get the latches to stay in an up position without jamming something to hold it up? If so, and I put my hardtop back on, when the rear pins drop and catch the latch, will it close and read as closed? Mines a 98 btw. It’s strange that it’s locked down but not reading that it’s locked
 

·
Registered
94 SL320 98 SL500 99 SL600
Joined
·
944 Posts
Thank you! This diagram is very helpfully. A bit confusing but I’ll spend time tomorrow comprehend everything it states.
So this will help get the latches to stay in an up position without jamming something to hold it up? If so, and I put my hardtop back on, when the rear pins drop and catch the latch, will it close and read as closed? Mines a 98 btw. It’s strange that it’s locked down but not reading that it’s locked
Check that all the micro switches are connected.
 

·
Premium Member
97 E-420 (180K miles), 97 SL500, (93K miles) 2015 GMC Sierra Denali 2500HD CC/SB/4x4 Duramax(55K)
Joined
·
4,194 Posts
I had an occasion this summer on my 97 where the soft top raised part way then quit. I could hear the click of the pump starting, but nothing else. After some troubleshooting, including checking the fuse for the top, the blades looked like some arcing had taken place. I rotated the fuse so the fuse blade would make contact in a new place and all was well. reversed the fuse, no operation. So I replaced the fuse. the element was ok, but the blades must have had enough arcing to raise the resistance of the connection to the point the top wouldn't operate. IIRC the fuse is like a 40A fuse.
 

·
Registered
1998 SL500 Black on black
Joined
·
14 Posts
Discussion Starter #15
I will make sure to do that. Here in Seattle it’s raining for the next week so I took advtange if no rain for about an hour and just manually put back the soft top and put the hard top back on. And of course another problem lol.

We somehow got the rear latches to stay locked up. And when we place the hard top back on, after catching the rear locks it dropped into place. It’s locked in the latch but is loose. The latch is not locked all the way down and I can move the rear of the hard top up and down. Wth is going on!
 
1 - 15 of 15 Posts
Top