Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
1990 Mercedes-Benz 420 SEL(RIP),1997 Mercedes-Benz E420
Joined
·
1,936 Posts
Discussion Starter #1
Windows, sunroof, signals, wiper, hazards,rear headrest button, don't work. Can anyone please provide me with the location of the Convenience module or any information on the issue. thanks
 

·
Registered
Dallas, Texas
Joined
·
7,715 Posts

Attachments

·
Registered
1990 Mercedes-Benz 420 SEL(RIP),1997 Mercedes-Benz E420
Joined
·
1,936 Posts
Discussion Starter #4
does it reset when you disconnect and reconnect the battery?
I appreciate the responses.

No it does not reset. I did try clearing the codes. Procedure went :
1. Disconnect battery
2. Connect battery terminals together using a jumper cable (same color for both sides)
3. Let it sit overnight
4. place key to ignition 2 setting for at least 2 minutes
5. start up.

but no avail.
 

·
Registered
1990 Mercedes-Benz 420 SEL(RIP),1997 Mercedes-Benz E420
Joined
·
1,936 Posts
Discussion Starter #5
Using test light check all fuses including rear fuse box.

CF module is in right front e-box. Didn't you have some fireworks in that area?
http://www.benzworld.org/forums/w210-e-class/1555903-w210-errors.html#post4450188

.
Thanks for the response
The fireworks occurred when we plugged the pollutant sensor back into the main wire harness, problem was with the wire on the sensor. After sparking we removed the part and even after trying to replace the part nothing has worked.
 

·
Registered
1990 Mercedes-Benz 420 SEL(RIP),1997 Mercedes-Benz E420
Joined
·
1,936 Posts
Discussion Starter #6
actually this makes sense to me... i remember a difficult time putting the clip back on this piece when I changed out the upper control arm. I believe it was damaged in the installation process... anyway to test? I wouldn't be surprised if this is insanely expensive.
 

·
Registered
Dallas, Texas
Joined
·
7,715 Posts
actually this makes sense to me... i remember a difficult time putting the clip back on this piece when I changed out the upper control arm. I believe it was damaged in the installation process... anyway to test? I wouldn't be surprised if this is insanely expensive.
Other then checking power supply and few inputs there is not much you can do. Access to CAN network is needed to evaluate further. Unit is $535. After installation it has to be coded using SDS.
 

·
Registered
1990 Mercedes-Benz 420 SEL(RIP),1997 Mercedes-Benz E420
Joined
·
1,936 Posts
Discussion Starter #8
Other then checking power supply and few inputs there is not much you can do. Access to CAN network is needed to evaluate further. Unit is $535. After installation it has to be coded using SDS.
Thanks. I made a call to one of the local shops. where did you get the 535 estimate if you dont mind me asking. is there any place besides MB? thanks again
 

·
Registered
1990 Mercedes-Benz 420 SEL(RIP),1997 Mercedes-Benz E420
Joined
·
1,936 Posts
Discussion Starter #11
anyone?

I went to a local European automobile shop and they said that all the metal pin does is secure the harness in place, which could be done with a simple tie strap. I tried this but still nothing... thing that interests me is that the reclining seats will work at times, but then at other times, nothing.

Also, I'm reading up on a convenience relay that according to a different post, is located under the rear seat...can anyone tell me where this is?

thanks.
 
1 - 11 of 11 Posts
Top