Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all! Just joined today. I wondered if anyone out there might have a sharp wit or some experience/insight into my problem. I recently purchased a used 2001 c240 with a manual tranny. Seemed alright from the "get go" but a couple days after started to have some problems. I have always noted that when car is in 1st gear it seems a bit sluggish, but just thought that this may be the way the car is. One morning, left for work and suddenly the car started bucking and almost killed. I took it into shop and was told all codes were "clear" & it was a leaky vaccuum hose. Replaced, and seemed to help at 1st but did the same thing next morning. Brought it back to shop and then it was decided it was the air intake valve. Replaced, and seemed to help. Since then, still have diminished power in 1st (like I'm pulling a load) and acceleration choppy in all gears. The sensation is subtle, but there none the less. Also, I noted that when car bucked it made a clunking noise under hood. The car idles better since air valve replaced but car still shakes while idling when car at stop. Not sure if all this is 1 or more problems. All this, of course has us fretting about the car. I have no significant records of major problems with car (but there are plenty of records being just off lease). Any insight into situation would be appreciated considering my mechanic is baffled (ugh!!!). Thanks
 

·
Registered
1984 280SEL AMG
Joined
·
701 Posts
Try the fuel filters, and the o2 sensor. They may not be pulling codes because the problem is intermittant ( soft codes that delete when car is shut off? )
Also it could be a timing issue, or the return fuel line valve, which is vaccume operated. Then their is your MAF sensor ( Mass Air Flow ) ( if so equipped )
Or you can have checked your TPS ( Throtal Position Sensor )

Lastly, When was the last time your car was tuned up completely?

Lastly check your fuel cap, could be causing a hydro loks stiuation ( sucks in air when opening )
 
1 - 2 of 2 Posts
Top