Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
W210, E280 ELEGANCE
Joined
·
33 Posts
Discussion Starter #1
I few months ago my dealer replaced my entire drivers door due to rust developing on the plastic strip that runs across the door. My car has at the moment 26 000 miles and is a 2000 E 280 Elegance.

The query that I have is that since only driven the car 4 times since I received it back from the body shop, isn't the computer on the car supposed to be reset or something due to the battery disconnected, because I have a strange temperature reading that isn't realistic. My setting is set on Deg C and is on the Kilometer reading. The other day, it was 29 deg C and my car read a temperature of 54 deg Celsius.

Is this temperature on the instrument dial the engine temp or outside temp or do I have a faulty
reading?

Two other queries.

1. Before I discovered the irregular reading, is that my girlfriend took the car on a 2 hour trip and had to stop to fill up with gas. The petrol attendant filled up the car and checked the oil and said there was no oil.

I was a bit upset as she told me that she filled my car with a can of high grade oil without telling me. Isn't the computer supposed to tell you that you have low oil and you shouldn't really bother to check the oil because it will be replaced on service A?
 

·
Registered
SLK320, MKV Jetta TDI, Mini Cooper S, Lincoln Mark LT
Joined
·
1,712 Posts
Check the position of the sensor. It should be in the front bumper on the left side. If it has been moved or damaged in some way, it may not be giving you a good reading. If your car is sitting still above the driveway for example, it will pick up the heat off of the ground. If your car is facing the sun, it may pick up that heat as well. If the sensor is too close to the radiator, it will pick up that heat too. If it gets wet and your car is moving, the evaporation will make it read too low.
 

·
Registered
W210, E280 ELEGANCE
Joined
·
33 Posts
Discussion Starter #3
Thanks E-Klasse but where is this sensor?
Is it next to the left hand fog light. I have the facelift model?

Another thing about the onboard PC is that since my girlfriend took the car and had it filled up with oil, isn't the pc supposed to show that their is low oil?

I told the dealer and had the pc checked and said it was 100% but im not sure if they checked it. Its going in soon for a service, I'll ask them again.

Another thing, is the message "mulfunction" supposed to read up when you start the car when you have a mulfunction?

Sorry Im asking this but when I drove the car with the fog lights on it read check lights - bulb fused. Today when I started the car it read no mulfunctions but as soon as I turned on the lights it read the mulfunction. I find this strange because doesn't the computer store the faulty mulfunction when you start up to remind the person that there is a mulfunction. Im a bit puzzled.

Thanks again E-Klasse

Silva[xx(]
 
1 - 3 of 3 Posts
Top