Mercedes-Benz Forum banner

21 - 26 of 26 Posts

·
Registered
ML320, 2001
Joined
·
14 Posts
Discussion Starter #22
Wow!!!! guys I am seriously discussing my 'headache' so someone could help me and it ended up in this kind of back and forth...please!!! cut it off and come on in with more help.Thanks
 

·
Registered
02 C32, 08 C350, 00 CLK320 (sis'), 01 ML430 (gone)
Joined
·
1,698 Posts
Wow!!!! guys I am seriously discussing my 'headache' so someone could help me and it ended up in this kind of back and forth...please!!! cut it off and come on in with more help.Thanks
my apologies.

my dealer traced the problem to the control unit on the transmission. there is a service bulletin saying that if there's an oil leak on the engine the oil may drip down and short out the sensor. that could be your problem as well. there is also an o-ring seal on the side of the transmission that may leak oil and cause the sensor to short out.
 

·
Registered
Joined
·
2 Posts
How old is the battery? When the battery voltage is 'marginal', that can set off bunch of the dash board lights. I can't think of one sensor/problem that can set of all those lights you mentioned at the same time. All those things have one common thing, all those sensors and ECU need correct voltage. Have an auto parts store check the battery and the alternator. Also, check the ground connections. There are several ground connections on ML.
Would it be the same for a 2002 E55? Thank i appreciate. Anything u can tell me. All my lights started coming on. Abs bas esp & check engine.
 

·
Registered
Dallas, Texas
Joined
·
6,764 Posts
Would it be the same for a 2002 E55? Thank i appreciate. Anything u can tell me. All my lights started coming on. Abs bas esp & check engine.
Necropost.
You have responded to post that is 11 years old.

Start new one. Describe in details what warning lights are on. History of vehicle and how problem started.

I have missed E55 bit.

Make your post in W210 forum.
 
21 - 26 of 26 Posts
Top