Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello all.

I have a 1997 Mercedes E300 and keep getting code P1367. was told to replace the #3 glow plug did that and still come right back on a/b 10 seconds after clearing.. Any ideas??? :confused:
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
any ideas anyone?

Like i said has code p1367. when first start up glow plug light goes out and start car up then glow plug light comes back on and stays on for a few minutes. But when do first start the car after sits a while sounds like a can of nails rattling? not sure what is going on at this point but defintely want to resolve this issue. she's my baby!!! :thumbsup:

any help would be greatly appreciated.:bowdown:
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Well just an FYI i figured it out i do believe. Did some research and found code p1367 means cylinders 3 & 4 glow plug malfunction. Since i replaced #3 then i unplugged the glow plug relay and checked every pin. Pin #4 was the only one showing any ohms .4. all others were 0. which is weird b/c everyone said that they should be around .4. So i removed the intake tube that runs from the driver to passenger side removed the glow plug connector and then it went to 0 so wham found the problem. Replaced the #4 glow plug and now no check engine light since cleared. Before was coming on right after cleared

The morning will tell more but hopefully all is well. Just figured i would let others know in case they have this same problem. :thumbsup:
 
1 - 3 of 3 Posts
Top