Mercedes-Benz Forum banner
1 - 4 of 4 Posts

·
Registered
1999 ML320
Joined
·
273 Posts
Discussion Starter · #1 ·
Hey, I'm looking to change a couple burned out bulbs behind my idiot lights and one behind my clock.

Read a few DIY, but there seems to be a little confusion about what bulb is actually back there. I've seen pictures showing the bulbs with the wider/beige bottom but autohausaz.com also shows a possible bulb with a smaller white base. The beige is listed as 12V/1.5W and the white as 12V/1.2W.

Does anyone know what bulbs go where? And are the idiot lights the same as the backlight for the clock ( I assume it uses a backlighting bulb, as I can see the figures but they it is extremely dim)

My vehicle is a 1999 Ml320.

Thanks in advance.
 

·
Registered
2002 ML55 AMG, 2005 Chrysler Crossfire Coupe Limited, 1999 C280
Joined
·
4,714 Posts
Okay, I'm idle so I did a search for you:D.

Have look at the pdf at post #10 in the link below:

http://www.benzworld.org/forums/w163-m-class/1472163-dash-bulbs-led.html

This link contains pictures of the back of the instrument cluster:

http://www.benzworld.org/forums/w163-m-class/1465434-instrument-cluster-snafu.html

This link contain information on how to remove and install the cluster:

http://www.benzworld.org/forums/w163-m-class/14906-99-ml320-odometer-not-working.html

In the link below, if you want the main instrument cluster lights it's the FIRST bulb and if you want the smaller lights (e.g. BAS/ESP, "Check Engine", Footbrake light bulbs etc.) it's the SECOND bulb:

Your Parts Search Returned 2 Part(s)

Good luck!:thumbsup:
 

·
Outstanding Contributor
2006 ML500 2002 ML320
Joined
·
17,900 Posts
Hey, I'm looking to change a couple burned out bulbs behind my idiot lights and one behind my clock.

Read a few DIY, but there seems to be a little confusion about what bulb is actually back there. I've seen pictures showing the bulbs with the wider/beige bottom but autohausaz.com also shows a possible bulb with a smaller white base. The beige is listed as 12V/1.5W and the white as 12V/1.2W.

Does anyone know what bulbs go where? And are the idiot lights the same as the backlight for the clock ( I assume it uses a backlighting bulb, as I can see the figures but they it is extremely dim)

My vehicle is a 1999 Ml320.

Thanks in advance.

There is a little problem here. It's either you typed wrong or AutoHaus does not have the right bulbs.

There are 7 illumination bulbs (marked green in the diagram) and they are 2 watts.

All the rest are 1.5 watts.
 

Attachments

·
Registered
1999 ML320
Joined
·
273 Posts
Discussion Starter · #4 · (Edited)
Thanks for the quick replies guys.

It seems like the 1.5 that AutoHaus has are correct for the warning lights but they don't seem to have the 2w. One last quick question. My clock still functions, but it doesn't quite light up. In the right light I can see the time on the clock, but it's impossible to see otherwise. I didn't see a bulb that was for the clock or the temperature display (I assume they are similar), so I'm wondering if anyone knows how I can get my clock back? All my gauges are lit up correctly (as far as I can tell), so I don't think any of those bulbs are responsible for the clock, perhaps it's just a standalone thing that needs to be replaced completely?

Edit: now that I look at it, I suppose the clock could be lit by one of the general "instrument illumination" bulbs. Specifically the bottom-most left one in that diagram. (A1e8 marked in green)
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top