Mercedes-Benz Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Is any one can help me, how can I determine if you need new regulator or alternator? Any indication as what could be wrong? My car has 55.000 miles but the light come on (Check battery Visit Workshop) and I keep charging the battery. How can I remove the alternator? Can I replace the regulator with out removing the alternator? [/FONT]



Thank you :bowdown: :bowdown:
 

·
Registered
Joined
·
72 Posts
Hi,

Do you have to charge your battery offten because you can't Start your Engine ?

Or do you only have the warning on your Cluster with no other problems ?

Maybe you only have to Change the Auxilliary battery, under the Climate filter.

Ask someone who has a multimeter and Check the Voltage.
Turn the engine on, and Go In the trunk with the multimeter to check the voltage.
Multimeter should be on "DC position", put the red pin on the + and black pin on the -.
You should have between 13,5 and 14,4 Volts.

If you have less than 12,5 Volts, then your alternator doesn't charge your battery.

Regards,
Frenchy.
 

·
Registered
Joined
·
3 Posts
there are 2 batteries in the vehicle,

1 is a large battery in the trunk, that is the systems battery.
1 is located under the hood, under the cabin air filter, that is the auxillary battery.

If the light is on in red and you can still drive, most likely its the aux battery not the alternator
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
there are 2 batteries in the vehicle,

1 is a large battery in the trunk, that is the systems battery.
1 is located under the hood, under the cabin air filter, that is the auxillary battery.

If the light is on in red and you can still drive, most likely its the aux battery not the alternator
thank you for the quick reply. I had remove the primary battery, on the Trunk and after i conected i start to received those messages. I have a charger and voltmeter. I will start the engine and check it. My questions is any way to check battery #2 under the cabin filter, because i attempt to charge and work for few days and then again the light come on. My last experience was horrible because the car come to halt and i was not able to drive untill recharge the primary battery.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
In the summer I remove the system battery for few months, and I was not aware of the auxiliary battery at the moment.
When I connected back to the car, the (System Battery) was fully charge, but that’s when I start to have the red light. I remove the cabin filter and I attempt at the time to charge the auxiliary battery. After that attempt the warning red light disappear however after a week it come back to a point that the ABS and all electrical equipment malfunction and the car come to halt until I recharge the system battery. I do own a voltmeter and I will check it out. Is anyway that I can check the Auxiliary Battery?

Thank you again, you where very helpful.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #7
I check the voltage and register 15.25 VDC. I attempted to recharge the Auxilary battery but got reall warm. The red light still symbol of battery and message to visit workshop. You think is the Auxillary battery?? anyway i can test it?


Thank you :surrender:
 

·
Registered
Joined
·
77 Posts
I had the exact same symptons. I replaced the auxillary battery $100 and everything is fine. I tested mine with a voltmeter and it read 9.6 volts and it would not take a charge. Batteries Plus, and Autozone have it in stock. Do not have the engine running when you test it.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #9
I had the exact same symptons. I replaced the auxillary battery $100 and everything is fine. I tested mine with a voltmeter and it read 9.6 volts and it would not take a charge. Batteries Plus, and Autozone have it in stock. Do not have the engine running when you test it.
I replace my main battery because when i check it after remove from my car it was show 9.78 VDC. With engine off the auxilary battery shows 13.17 VDC. With engine running i check the alternator by putting my voltmeter on the battery while was the car running and show 17.15 VDC. Now that i change the main battery can't even drive the car anymore. SRS Malfuction, ABS Malfuction, Check engine light VISIT WORKSHOP and Battery light is red.

Please help
Thank you
 

·
Registered
Joined
·
35 Posts
I had the same problem, I replaced the auxiliary battery and the problem was solved. If you still have a problem with charging, try to start small and then go big. There is a relay that switches around the charging cycle from the alternator to the two batteries. It is not expansive and you can replace it easily.
relay.jpg
 

·
Registered
Joined
·
22 Posts
Discussion Starter #11 (Edited)
ESP MESSAGE

I replace both battery's and still get 3 messages warning ESP, battery, SRS. When i have key to position 1, before starting the car only ESP is on and i heard a whird noice coming...
When i start the car disable all electrical equipment included transmission, so i can't even drive to the dealer...
I was not be able to find the relay that switch the charging between primary and auxilary battery. Is the location above the Auxillary battery? or on the other side by the fuse box?
When car running and check with Voltmeter shows 18.40 VDC.


Thank you :cool::cool:
 

·
Registered
Joined
·
35 Posts
If the Voltmeter shows 18.40 then i think the alternator and the relay is fine, the only thing you can do now is to check the fuse box (one by one), including front of the car and in the trunk. If you did not find a burned fuse then you have to take it to the MB dealer.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #13 (Edited)
I conect my Charger to the main battery and was charging for 2 hrs and show completed charge. If i conect to the car and leave over night then it discharge complete. So it may have short some where. I haven't instaled any electrical part on the car at all. I can't put the car to Gear to drive to the dealer everything is disable once i start the car.I think something is wrong with electrical stuff on the car any clues? . :surrender: :surrender:
 

·
Registered
Joined
·
4 Posts
I'm having the same issue with the esp, abs lights and the car not going into gear. Both batteries fully charged. WEre you able to figure out the problem?
 
1 - 14 of 14 Posts
Top