Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,621 Posts
Discussion Starter #1
Omg my brain is fried. I need help. What would cause this to show up?

Mercedes mechanic says I'm missing a check valve at the fuel tank from tank to evap canister that is causing this. I am unable to find this check valve.

This is what is supposedly preventing my car from entering ready status for smog check. I suspect based on live data my car is favoring on the rich side if this means anything.

Help help help!!! I'm confoosed!
 

·
Registered
nothing broken. finally!
Joined
·
2,619 Posts
Generally it means there is an issue with an O2 sensor... or the data it is receiving from them is interpreted weird.

Keep in mind that those emissions people will fail on anything. You might as well pass smog just fine but if anything is detected, its fail. Here, even if you are throwing a transmission code you are failing...
 

·
Registered
Joined
·
1,621 Posts
Discussion Starter #3
Generally it means there is an issue with an O2 sensor... or the data it is receiving from them is interpreted weird.

Keep in mind that those emissions people will fail on anything. You might as well pass smog just fine but if anything is detected, its fail. Here, even if you are throwing a transmission code you are failing...
See I'm not getting a code.....my obd2 won't even get ready status. Last night I pulled my evap canister and it was pretty dry.

Sent from my SGH-T989 using AutoGuide.Com Free App
 
1 - 3 of 3 Posts
Top