Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
OK I have a 2004 CLK500 AMG package - in mint contdition - roof normally works easy but one day it tells me that the safety wall is not latched in the trunk, hence it cannot open the top up to put down...I tried everything making sure all ends are engaged and pulled tight ..... is there a sensor for this issue that needs to be replaced - the motor is perfect just the message states that this safety wall (the plastic you pull up for the window) is not engaged BUT IT IS! any thoughts?
 

·
SuperModerator
1986/1990 W126
Joined
·
13,662 Posts
Yes I drove one of these a while ago and discovered a clothes peg on the sensor in the boot was key! Can't remember where though.

Moving to CLK section so you'll get specific information.
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
19,236 Posts
So it's telling you the trunk partition is not closed? There are three possibilities. The most common and easiest to fix is that the Lift-O-Mat struts that hold the partition in place have failed. When you pull the partition back to the closed position, it should be very tight and take a good bit of effort to push back open. If not, it's probably those struts. There are many posts about this in the forum:


If it's not the struts, then it could be that the plastic "pegs" on the ends of the partition cover that mate with the slots on the sides of the trunk lining are broken. There are micro-switches in those slots that register the partition as being closed so if the pegs are broken, the switches son't be tripped. Also, the switches themselves can go bad.
 

·
Registered
2004, CLK 320
Joined
·
4 Posts
OK I have a 2004 CLK500 AMG package - in mint contdition - roof normally works easy but one day it tells me that the safety wall is not latched in the trunk, hence it cannot open the top up to put down...I tried everything making sure all ends are engaged and pulled tight ..... is there a sensor for this issue that needs to be replaced - the motor is perfect just the message states that this safety wall (the plastic you pull up for the window) is not engaged BUT IT IS! any thoughts?
Hi Cattz
If you get some paper or cardboard, open your boot on the left side arm there is a hing locking sensor, stuff it with paper or cardboard as if the sensor is connected, and your roof will work again. I have the clk320 same problem, and it fixed the problem for years. hope its helpfull for you. Have a sweet Weekend. Phillip
 

·
Registered
'79 450SL, '04 CLK200 convertible; former A124, W210, A209.
Joined
·
1,383 Posts
Yep, same trick as Philip showed worked on two CLKs for me, I glued a tiny piece of plastic on top of the sensor. Works a treat 👍
 
1 - 6 of 6 Posts
Top