Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
02 E320 4-matic Wagon, 97 540i
Joined
·
165 Posts
Discussion Starter #1
Hey guys haven't been here in a while...I can't take it anymore, at least half of the characters on the display are gone...is the a DIY for this like the gauge cluster...? if not does anyone know where i can send it...? thanks as always..

Brent
 

·
Premium Member
2001 E320 - Brilliant Silver/Ash: 107,000+
Joined
·
17,193 Posts
Instructions for the DIY are in the stickys. If those fail you can send it out for repair. Sorry I don't remember where you can send it but someplace in Massachusetts comes to mind. Welcome back.
 

·
Registered
02 E320 4-matic Wagon, 97 540i
Joined
·
165 Posts
Discussion Starter #3 (Edited)
thanks, but i must be a moron because i can't find it and i've been searching for a while now...i can't even see what the temp is set at...
 

·
Registered
02 E320 4-matic Wagon, 97 540i
Joined
·
165 Posts
Discussion Starter #5
am i crazy or are all of these about the gauge cluster lcd's....i'm talking about the climate control lcd above the radio
 

·
Registered
1999 E55, 2001 E320, 1990 560 SEC, 2004 ML350, 2001 ML55, 1995 S500, 1998 SL500, 2010 E550 Sport zoo
Joined
·
7,035 Posts
I would shop for a used unit with good display 210 830 2285 part#
 

·
Registered
02 E320 4-matic Wagon, 97 540i
Joined
·
165 Posts
Discussion Starter #7
yeah, just started searching...seems 250 beans is the average price...thanks
 

·
Premium Member
2001 E320 - Brilliant Silver/Ash: 107,000+
Joined
·
17,193 Posts
am i crazy or are all of these about the gauge cluster lcd's....i'm talking about the climate control lcd above the radio
No not crazy but maybe I am for misunderstanding you. I think it was ohlord who said that once those crystals go bad there is no fix for them.
 

·
Registered
2000-E320, 2012 Buick Enclave, 2004 Ford Ranger, 1973 Rolls-Royce Silver Shadow
Joined
·
194 Posts

·
Registered
1999 E55, 2001 E320, 1990 560 SEC, 2004 ML350, 2001 ML55, 1995 S500, 1998 SL500, 2010 E550 Sport zoo
Joined
·
7,035 Posts
The eBay part is the wrong part #. See correct part # in my previous post.
 

·
Registered
99 E430, 01 E430 Sport, 00 SL500
Joined
·
3,266 Posts
Don't waste money, time, effort to replace the ccu display. MB engineering had a workaround solution for your particular problem.
Pressing both "Up" and "Down" buttons, the temperature setting is set at 72 degrees F.
If you want to set driver's side at 66F, press "down" 6 times. To go to 80F, press "up" 14 times. It's safer to count while keeping your eyes on the road instead of starring at the display.
You will need to show your passenger how to set his/her side.
 

·
Banned
1999 E300 TD
Joined
·
2,045 Posts
You are correct, some folks think there is fooproof IC pixel fix, but quickly find out otherwise, and assume a pixel is a pixel therefore the AAC control can also be fixed. Very wrong thinking-----there is no known credible cost effective repair fix!!! If there is now is the time to sell your service!

To restore the unit, you will need to purchase a new one or purchase a working used one. If you purchase a non working used from a scrap yard, make sure it comes out of a similar chassis and returnable if the replacement also has a pixel problem.

Otherwise like the gent said start counting!!
 
1 - 12 of 12 Posts
Top