Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
6,456 Posts
Discussion Starter #1
A few months back I had the duo valves replaced because I wasn't getting cooling and the middle front vents were not thermally "equalized," and there was that hissing also. Fast forward today: Ambient now is in low 50s (F). No air coming from middle front vents in normal temperature, say 72F. Duo valves "thump" in no consistent fashion that I can speak of. If I set to LO, the vents open and I get quasi-warm air, duo valves stop thumping. I tried to run the diagnostics - can't get past the portion where the red flashing light comes on, so I can't get the codes. Help!
 

·
Premium Member
Joined
·
6,456 Posts
Discussion Starter #3 (Edited)
You have to read the codes, or at least sensor values. Are you pressing the right button?
I believe I'm following the instructions well - please note that the red led on my left AUTO button is malfunctioning (comes on whenever it feels like!)

  1. Ignition in ON position
  2. Left Temp HI; Right Temp LO
  3. Press REST+EC for more than 5 Secs
    Red led on RECIRCULATE button flashes but I don't get "di R"
  4. If I press left AUTO button, nothing happens
  5. If I press right AUTO button I get the following on the screen
    E
    Eb1 234
    E FF
    E
    And the cycle repeats
What do these codes mean? Could the malfunctioning left AUTO button be causing this odd diagnosis? Is that a malfunctioning sun sensor? What about the FF
 

·
Premium Member
Joined
·
17,193 Posts
Agreed that you must get the sensor values but don't forget the middle vents don't emit much air anyway. What you are observing might be perfectly normal. Most people advise ignoring the b1234 but that is part of the system and must be functional for your HVAC system to operate at peak efficiency.
 

·
Premium Member
Joined
·
11,367 Posts
As you have chosen not to complete your profile with details of your model, it is not possible to look up details in my WIS....
 

·
Registered
Joined
·
35,769 Posts
Dang. I would assume that with over 5000 post on this forum you know basic stuff on the car :D
With the ignition on hold REST down for over 5 seconds and when you see display change, scroll it up or down by pressing AUTO on both sides.
Don't forget that for proper interpretation we need at least 2 sets of values. First with engine off and second with engine warm and on.
On the other hand your aging car might suffer from broken clima element, so play with the manual override on flow directions and see if it changes.
Clear the sun sensor code as it might bring it back to life.
 

·
Premium Member
Joined
·
6,456 Posts
Discussion Starter #10
As you have chosen not to complete your profile with details of your model, it is not possible to look up details in my WIS....
OK, Profile Cop, I know you are just doing your job. Usually I include the model year when I post. I didn't do it here and I'm sorry, really really sorry, and hope the punishment is minimal. It is a MY01 E430.
 

·
Premium Member
Joined
·
6,456 Posts
Discussion Starter #11
Dang. I would assume that with over 5000 post on this forum you know basic stuff on the car :D
With the ignition on hold REST down for over 5 seconds and when you see display change, scroll it up or down by pressing AUTO on both sides.
Don't forget that for proper interpretation we need at least 2 sets of values. First with engine off and second with engine warm and on.
On the other hand your aging car might suffer from broken clima element, so play with the manual override on flow directions and see if it changes.
Clear the sun sensor code as it might bring it back to life.
LOL! Thanks for the instructions. It is complicated with me when it comes to MB - bottom line, I hate to spend more time than necessary to deal with crappy designs - thus basic stuff for me is what is in the owners manual with these cars. I care less for MB products than you can possibly imagine.
 

·
Registered
Joined
·
35,769 Posts
I have all the manuals for my car, but remember reading only the page with FSS reset.
The clima sensor reading is not in the manual and I found that great option on this forum. Have to admit that occasionally I have some fun with it when DW is driving.
You know you can display speed on the clima LCD? This way you can know exactly how fast she is driving without lurking on the main cluster.
 
1 - 12 of 12 Posts
Top