Mercedes-Benz Forum banner
1 - 8 of 8 Posts

·
Registered
420SEL
Joined
·
1,299 Posts
Discussion Starter · #1 ·
I know this was talked about, but I just want to make sure once more before I change this part.

Heat works good through all settings, but sometimes goes crazy and starts blowing very hot air even at low TEMP setting, unless I press the COOL outside air button and then only center vents will do so.

When uing AC, Most of the times only the center vents blow cool, Defroster most always blows HOT and sides vents have a mind of their own, forcing me to only use center vents, meaning using a defroster in summer will sucks ass.

Sounds like an air distribution problem. Is it the DuoValve or the flaps not engaging properly.

Thanks.

Dave
 

·
Registered
'07 S65 AMG '95 S600 '98 E430 '83 300SD '81 300D
Joined
·
111 Posts
I am experiencing the same issues....even after having RBM (local dealer) replace the DuoValve!!! What's up?
 

·
Registered
1995 S600 (sold)
Joined
·
1,127 Posts
You need to pull codes to narrow down the possible causes.
 

·
Registered
420SEL
Joined
·
1,299 Posts
Discussion Starter · #4 ·
Will do that today and see what comes out.


Dave
 

·
Registered
03 S500/99 SL600/94 S320-sold/86 560sl-sold/87 560sl-sold/87 560sec-sold/88 300E-sold/88 420SEL-sold
Joined
·
111 Posts
I have a 1994 S320 doing the exact same thing. Has anyone ever figured out the cure?
 

·
Premium Member
SL55, 300SE, GL450, Daytona 955i
Joined
·
10,293 Posts
asodergren said:
I have a 1994 S320 doing the exact same thing. Has anyone ever figured out the cure?
i leave the blower at AUTO and temp at 72* all year long, mine attempts to fry my GF alive everynow and then as well... but thats only during the winter... havent had the problem since it got warm enough to start the AC on 72* and auto setting.
 

·
Registered
94 S-420; 91 300SL; 88 300TE; 84 190D; 01 GMC Denali
Joined
·
235 Posts
I was through the same problem with my black 1994 S420 (at 135,000 miles). I bit the bullet and bought a new duo-valve for over $400.00. It worked great...for about a month! Because I about had it with the hot air out the side vents, I unfastened the main hose going to the duo-valve and put a 3/8ths to 1/2 socket adapter in the hose about 3 inches from the end and put a hose clamp around it. After that, I had plenty of cold air from all vents. Once winter was on its way, I simply removed the socket adapter and enjoyed a warm and cozy car during the cold. The procedure is not very unsophisticated....but it is a sure thing. I sold the car a couple of years ago and the guy I sold it to does the same thing as the seasons change. Chasing a duo-valve is expensive...but fix was cheap.
 

·
Registered
1995 Mercedes S 320
Joined
·
8 Posts
Bypass Duovalve

Interested in knowing which hose is the correct one to plug with the 3/8" hose and socket w/ clamp.


Symptoms: Heat coming out of front side vents when A/C is on.


Also Indie Benz Repair plugged my car to diagnostics machine and it stated errors about duovalve
 
1 - 8 of 8 Posts
Top