Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Im sure this thread has been posted before but why not enter it any way.


My problem is that im running 19 x 8.5 wheels front and 19 x 9.5 rear, the wheels fit but when i drove around my apartment complex before taking it to the street i noticed a sqeaking and clicking noise. I just had my front and back brake pads and rotors done, and there seems to be no rubbing only a slight scrap from the splash gaurds from what i noticed. Also i believe my lug nuts are too short because they became loose when i stopped to take off a wheel to check out the noise.

I was thinking i need to lift it but i like how they look now any suggestions? :confused:
 

·
Registered
2002 CLK 430
Joined
·
191 Posts
I used to run the exact same setup that you have. I had no problems with rubbing, etc. The issue I did have however was installing a lug lock/key on the wheels which were slightly too long. It resulted in the rears unhinging the emergency brake spring which caused a clicking noise, and the fronts made a rubbing sound. Removing them, the front rubbing sound went away, and the emergency brake assembly had to be replaced. (a $30 "improvement" ended up costing ~$300 to fix)
 

·
Registered
2001 CLK55 AMG, 2002 C32 AMG
Joined
·
1,637 Posts
i agree the clicking is most likely the lug bolts contacting the parking brake springs. the rear lug bolts only have about a 2mm window between too long and too short, you will probably have to keep shortening your lug bolts until you get them to not make noise anymore, but remember the small window, dont reduce the length drastically. the fronts dont really matter how long they are if i remember right, just make sure they arent too short. i cant remember how many turns should be out the back, 6-8?
 
1 - 4 of 4 Posts
Top