Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1990 190E 2.6 | 2001 E55 AMG | 1983 300D
Joined
·
4 Posts
Discussion Starter #1
Hi all,

I just purchased my first 190E - a 1990 2.6, 158k mi. Love the car. I would like to do a few things to it to improve its condition. Any input from experienced owners would be greatly appreciated. I am new to the W201 but not Mercedes as I currently own a W123 and W210.

One thing I would like to address is there is some residue that surrounds the gauges in the instrument cluster - it almost resembles mold. It appears to be a powdery substance. I am not sure what it is, but if this car is like the other Mercs I have messed with, the clear lens does not separate easily from the rest of the cluster. Is this correct? I am assuming I will need to remove the cluster, and remove the gauges from the cluster housing and clean the cluster housing through the gauge holes. I located instructions how to remove cluster so that sounds easy enough. I have removed it from the W123 and it seems similar except no oil line to deal with.

The wood trim surrounding the shifter seems to be cracked from the sun and has ridges. Any idea on the cost of this piece from dealer? If it is like the W123, I assume it is pressure fitted. It looks like I will need to remove the shifter trim and it should lift up.

Also, the shifter knob is scratched pretty badly. I have never removed one of these. Is it a straightforward process to remove the actual knob?

Idles rough when cold but runs great when it warms a little. Seems to be several possible problems that could cause that after searching the forums. Looks like mainly vacuum related issues. Will investigate this.

Noticed some strange climate control issues, but they are not a big deal. Sometimes the driver’s vent blows warm when the center vents are ice cold with A/C, when the climate control is set for max cooling.

Can someone explain the difference between the A/C button and the dehumidify button?

Temp wise, the car seems to run a little on the cool side - the hightest I have seen the temp gauge is around 75°C. Never even hits the 80°C mark. Does this seem a little low? Perhaps needs a new thermostat?

I absolutely love the way this car drives. I haven’t ever had the opportunity to drive a W201 until I drove this one, and have been very impressed. It is definitely a car you take the long way home in.

Thank you.
 

·
Registered
1985 w201 Euro 2.3-16vlv / 1992 w201 2.6 Sportline Manual
Joined
·
6,726 Posts
getina50 said:
Hi all,

I just purchased my first 190E - a 1990 2.6, 158k mi. Love the car. I would like to do a few things to it to improve its condition. Any input from experienced owners would be greatly appreciated. I am new to the W201 but not Mercedes as I currently own a W123 and W210.

One thing I would like to address is there is some residue that surrounds the gauges in the instrument cluster - it almost resembles mold. It appears to be a powdery substance. I am not sure what it is, but if this car is like the other Mercs I have messed with, the clear lens does not separate easily from the rest of the cluster. Is this correct? I am assuming I will need to remove the cluster, and remove the gauges from the cluster housing and clean the cluster housing through the gauge holes. I located instructions how to remove cluster so that sounds easy enough. I have removed it from the W123 and it seems similar except no oil line to deal with. some models actually did have an oil line. But yes its straight forward and the easiest way would be through the guage holes, but the plastic is held on by glue which becomes weak over the years and will break, many people do it that way as well.

The wood trim surrounding the shifter seems to be cracked from the sun and has ridges. Any idea on the cost of this piece from dealer? If it is like the W123, I assume it is pressure fitted. It looks like I will need to remove the shifter trim and it should lift up. Correct, getting the surround off is simple, keep en eye out on ebay for these things as they do pop up a lot for cheaper than the dealer

Also, the shifter knob is scratched pretty badly. I have never removed one of these. Is it a straightforward process to remove the actual knob? Assuming you have an auto the knob and lever are one piece that is removed by the nut at the bottom of the shifter

Idles rough when cold but runs great when it warms a little. Seems to be several possible problems that could cause that after searching the forums. Looks like mainly vacuum related issues. Will investigate this. Good idea

Noticed some strange climate control issues, but they are not a big deal. Sometimes the driver’s vent blows warm when the center vents are ice cold with A/C, when the climate control is set for max cooling. Center vents only blow cold air/outside temp air never hot, as for drivers vent blowing warm you may have a leak, pull out the vent and inspect.

Can someone explain the difference between the A/C button and the dehumidify button? They do nearly the same process

Temp wise, the car seems to run a little on the cool side - the hightest I have seen the temp gauge is around 75°C. Never even hits the 80°C mark. Does this seem a little low? Perhaps needs a new thermostat? Correct, you car t-stat may be old and getting incorrect readings. Always a good idea to change if you believe reading are wrong.

I absolutely love the way this car drives. I haven’t ever had the opportunity to drive a W201 until I drove this one, and have been very impressed. It is definitely a car you take the long way home in. Glad you have begun to appreciate the wonders of the w201

Thank you.

Welcome to the w201. :thumbsup:
 
1 - 3 of 3 Posts
Top