Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
mercedes 300sel
Joined
·
143 Posts
Discussion Starter #1
so ive had this problem since i bought the car. you guys helped me find out possible problems what this could be. so i changed the guide rod bushings and they were completely dead, havent been changed in 25 years. the noise going over bumbs is much less when they are biger holes. but still there is clanking noises when driving. after changing the guide rod bushings, it was sent to the dealership for an alignment. so you you guys have any ideas what else could this be? any help woudl be very much appreciated. i dont like fixing a problem without it being completely fixed.
 

·
Registered
Two '87 570SECs, one '87 560SEL
Joined
·
4,448 Posts
What kind of car, what year, how many miles, is the noise in the front or back, etc. We need more info before a decent evaluation can be made.

126's with hydraulic rear suspensions usually collapse the rubber bushings on the top of the rear hydraulic assemblies, resulting in a noise in the back of the car.
 

·
Registered
mercedes 300sel
Joined
·
143 Posts
Discussion Starter #3
the noise is in the front still. i replaced the guide rods becasue of that and still some noise comming. no rear self leveling. 1983 300sd
 

·
Registered
Two '87 570SECs, one '87 560SEL
Joined
·
4,448 Posts
Need more info. Does the noise only happen over bumps? Does it occur only when turning, is only left turns or right turns. How about a full description of the sound, when it occurs, how it occurs, etc. I'm trying to help but need additional data.

Original tires/rims? Low speed noise or only high speeds? etc. Have they determined that the dog-bone rubbers are fine when they replaced the brake thrust bushings? Tie-rod ends? Ball joints ok??

Where are you located?
 

·
Registered
mercedes 300sel
Joined
·
143 Posts
Discussion Starter #5
ok the noise is always there. turning right and left fast and slow, at every bump it clanks. the bushing were dead i changed them myself. the entire front end i just replaced. steerign shock, idler arm, 2 tie rods, lower ball joints, drag link, so i guess you can rule those out. all that hasnt been changed is the upper control arms. i did notice that the upper ball joint wasnt in great shape and the part that attaches to the stabalizer bar has alittle play. i dotn think that is casueing the noise. can it be that the guide rod need to be extended further? because it was the dealeership that adjusted everything after i installed all that
 

·
Registered
93 190E 2.6; 82 300 SD Turbo
Joined
·
1,678 Posts
I have an 82 300SD and i get this rubbing / squeaking noise that is coming from my driverside front area. It maybe the same sound that u are getting, I haveto replace either the ball joint or the steering rod tie (end).
 

·
Registered
Joined
·
1,285 Posts
Worn flex discs have beenknown to make this clunking noise, and on older MB's should be replaced as a ,atter of course.
 

·
Registered
Depends on the day!
Joined
·
13,337 Posts
I would wager your ball joints given that your guide rods were in such sad shape, the ball joints are prob. equally so.. I would also take a Good look at the upper control arm bushing and joint.

Jonathan
 

·
Registered
mercedes 300sel
Joined
·
143 Posts
Discussion Starter #10
well the lower ball joints and all tie rods are brand new. maybe 30 km on them. i also doubt its the flex disks becasue the ingagement into drive or reverse is smoth no initial clank. and im quite positive its coming fromt he front end. sound like something is loose hitting something. but im running out of ideas. control arms upper would be my next bet becasue i knwo for a fact there not perfect
 
1 - 10 of 10 Posts
Top