Mercedes-Benz Forum banner

1 - 2 of 2 Posts

·
Registered
2006 CL600 2011 C300
Joined
·
125 Posts
Discussion Starter #1
OK, just a basic question for those of you who can answer this...

And Mercedes Mechanic... maybe you can make mention of what SHOULD be the factory boost level??

I am just trying to get some numbers here... If anyone has solid info on this I would appreciate it.

My car 'factory' is at 13.3 using a ODBII scan adapter tool reading it through my phone running Ian Hawkin's 'Torque Pro' app.

And... does anyone know of the boost amount the 'big boys' like Kleemann, Renntech or Speeddriven have your car running at once they have flashed the ECU?

Maybe I should start another thread for that....??
I would guess most people do not know as there is no factory boost gauge...
 

·
Registered
2006 CL600 2011 C300
Joined
·
125 Posts
Discussion Starter #2
I just talked with a guy at Kleemann and my boost level is very low. Seems factory you should be about 18 PSI.

But, my ODBII reading comes from the top pressure sensor off the IC. So that may be the reason for the low boost reading.

I was just wondering if anyone else here has possibly taken a reading from the ODBII and what reading they have from it.

There is a rhyme behind my reason for asking BTW...LOL.

Oh... and I was also told if you are a member at MBWorld Kleemann has a sale for their flash going on now for $995.00 Reg. $1695.00

I do not know if I am allowed to post that here or not?? If not, sorry... a mod can delete.
 
1 - 2 of 2 Posts
Top