Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Premium Member
M120, M119, W126*2 + Silver Avantgarde wagon
Joined
·
4,742 Posts
Discussion Starter #1
Heh gang - help!!

My delightful chrome handle on my trunk has stopped working, have to slam trunk, but close assist still works.

HELP!

Any solutions...? :thumbsup:
 

·
Registered
1997 S500V, 1999 S500 grand edition, 2006 s65 amg
Joined
·
7,356 Posts
Heh gang - help!!

My delightful chrome handle on my trunk has stopped working, have to slam trunk, but close assist still works.

HELP!

Any solutions...? :thumbsup:
are your locks getting slower? the handle has to do with Lock Pump not close assist.

does the striker eye still work?
 

·
Premium Member
M120, M119, W126*2 + Silver Avantgarde wagon
Joined
·
4,742 Posts
Discussion Starter #3
Heh Buddy - let's talk tomorrow for sure about the cam oilers... sorry it's been so hectic

So back to the trunk... Lock pump sounds more encouraging than close assist $$$ wise. My driver locks works fine but the central locking never worked since I bought it.

R
 

·
Registered
94 s420 250kmiles
Joined
·
827 Posts
And there's the problem crack that thing open and check it out, mine was as simple as a loose wire.

sent from my HD2 running Android 4.1
 

·
Registered
1997 S500V, 1999 S500 grand edition, 2006 s65 amg
Joined
·
7,356 Posts
Heh Buddy - let's talk tomorrow for sure about the cam oilers... sorry it's been so hectic

So back to the trunk... Lock pump sounds more encouraging than close assist $$$ wise. My driver locks works fine but the central locking never worked since I bought it.

R
ok i will try to call you tomorrow, the lock pump controls alot of things sadly. if you disconnect it your car wont start but they are not cheap either. but it can also be a leak in the system that will also cause issues. on mine the doors would lock 15 seconds late and my leak was for the trunk striker. i bought about 5 of the trunk latch assemblies until i found out it was a minor leak(i was still getting air through the hose but only the handle was working so i never thought it was leaking) My leak was the nozzle on the pump, you never know you might have leaks over there to causing your central locking to not function.
 
1 - 6 of 6 Posts
Top