Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 99 CLK 430 with 40k miles. The check engine light randomly comes on and goes off. Took it to get checked out and was told it was the cat and 02 sensor which is making the fuel mixture rich. He also said it was common problem on these cars and the dealer should take care of it. Has anyone else had the same problem?

Thanks for your input.
 

·
Registered
1977 RD400
Joined
·
10 Posts
The MIL codes are a good source of info but rarely correct in and of themselves. If you ha...

The MIL codes are a good source of info but rarely correct in and of themselves. If you have a single bank (one side of the engine) MIL for O2 sensor value out of range its more likely the MAF gone bad. When MAF's drift out of calibration the symptoms are the left bank running rich- a documented problem with MBZ's. The emissions warranty is up to 70K miles in some states- take it to the dealer. You really need to get the car on a MBZ Star Diagnose machine which can tell you far more about the car than any MIL code puller.
 

·
Registered
99 clk320 cabriolet
Joined
·
4 Posts
yup. I have a 99 clk and it came on just before the K &N filter i installed...It stayed off for 36 miles...when i got to work it came back on..its been a month.
 

·
Registered
214 SL63/2015 E63s Estate
Joined
·
34 Posts
RedSeaDude - 3/9/2004 10:16 PM

Happened to my 02 CLK55AMG;
Was told misfiring - replaced Air Mass Sensor..
Haven't happen since..
Happened to mine too but in my case all it took was to turn off the engine, take off the gas cap and put it back on. This from the service manager so I guess he'd seen that before!
 

·
Registered
SL320, 300e, 450SL
Joined
·
1,044 Posts
This has not yet happened to me, but thanks for the warning in advance. Im sure any day now.[:D]
 
1 - 8 of 8 Posts
Top