Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
2001 S430
Joined
·
96 Posts
Discussion Starter #1
My 2001 S430 "Check Engine Light" goes off and on periodically. The dealer replaced the O2 sensor but this didn't fix the problem. Car runs fine even when the light is on. Anyone else have this problem? If so, what caused it and how was it fixed? Thanks.
 

·
Registered
2007 S550 Sport
Joined
·
911 Posts
my 02 S500 light is on too ! Dealer changed air intake and now has to change other things too.
Strange isnt it?

brad
 

·
Registered
MB CL500(C215);SL55(R129), SL63(R230)
Joined
·
493 Posts
When "check engine" is lit, it clearly says check ECU with Stardiagnosis.
Other tools may be available but the output is sometimes not much useful.

Serious errors will make "check engine" permanent on.
Errors which disappeared after defined driving cycles can make the light of again.
And minor errors could mot even make the light on but are stored in ECU
 

·
Registered
2001 S430
Joined
·
96 Posts
Discussion Starter #4
It is strange. I've already had it in once and I've read other posts here that imply that the 00's thru 03's have this problem. I'm beginning to think that it's some kind of software issue. I'm going to take it back to the dealer and I'll let you know what they say.
 

·
Registered
2007 S550 Sport
Joined
·
911 Posts
my yellow check engine light is permenantly on right now. THey will fix it as soon as they get the part. I was in this past Tuesday so they said it is ok to drive around.

brad
 

·
Registered
2005 S500 4Matic
Joined
·
50 Posts
I have a 2000 S430 and my check engine light stays on too. I had mercedes technician look at it and he put on the computer and it said that the oxygen mass sensor was going bad. He said that it didn't hurt to drive it that way but as the sensor got worse the performance and the efficiency of the motor would drastically get worse.
 

·
Registered
'14 CLS63 AMG S, '10 GLK350, '03 SL5000
Joined
·
289 Posts
Suggest You Take It To AutoZone or Checker Auto

Hi, from Gordon Haines, visiting from the '05 SLK forum.

Your local parts store like Checker, AutoZone or Pep Boys can read the ON-Board Diagnostic (OBD) code to at least give you some idea of the source of the problem. They normally do not charge for this. (All late model cars have this in the USA.)

Their reading will not be as detailed as the dealer's but it is worth a few minutes to do.

You can find a list of the codes at the following Website:

http://www.yotatech.com/~corey/tech/dr_z_obd/dr_z.htm
 

·
Registered
2001 S430
Joined
·
96 Posts
Discussion Starter #8
I took the car in yesterday and the tech said that the problem was most likely emission related. Said that this problem on these cars was very common. I'll let you all know what the results are when I hear later today.
 

·
Registered
2001 S430
Joined
·
96 Posts
Discussion Starter #9
I took the car in yesterday and the tech said that the problem was most likely emission related. Said that this problem on these cars was very common. I'll let you all know what the results are when I hear later today.
 

·
Registered
2001 S430
Joined
·
96 Posts
Discussion Starter #10
OK. Picked up the car last week and as it turns out, they replaced a mass airflow sensor. The light hasn't come on since. We'll see if this fixes it for good.
 

·
Registered
Joined
·
1 Posts
My check engine light just come up also. And the DTC code is P0410 "Secondary Air Injection System Malfunction" Anyone ever seen this code before. I am new to MB and also new to Benzworld also. Any recommendation would be appreciated. Thanks.[:)]
 

·
Registered
2002 W220 S500 (AMG trims)
Joined
·
10 Posts
Replaced MAF, now "Secondary Air Injection System Malfunction"

As in the title. Can you share with me the solution to the Secondary Air Injection system? What had been fixed/replaced? Many thanks.
 
1 - 12 of 12 Posts
Top