Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1994 SL500
Joined
·
137 Posts
Discussion Starter #1
The check engine light on my 500 SL triggered. I checked the codes with car soft and got a "O2 sensor heater circuit" In all the programs I have access to I have not found any information on that circuit operation or how to check it. I cancelled that code and it has not returned. It has since thrown codes for steering high pressure cut off, ABS system feed, ASR system feed and the last code was last night code 6 pin 7 which according to the code chart is not applicable to U.S. vehicles. to date none of these codes have returned but pin 19 has had a consistent code 4 air injection system faulty and code 5 egr system faulty. These codes will not cancel for some reason but do not seem to be triggering the light, every time that the light has triggered there has been at least one other code. The clutch on the air pump is working and the pump is pumping air. The egr system seems to be functioning properly except that the passage in the intake manifold is plugged, just discovered that this morning and have not had a chance to r&r the manifold to clean it out. Any ideas why these codes will not cancel and why I keep getting these odd ball codes sporadically. Anyone have any ideas?
 

·
Registered
'97 SL500, 06 Subaru Outback, LL Bean 3.0
Joined
·
735 Posts
The check engine light on my 500 SL triggered. I checked the codes with car soft and got a "O2 sensor heater circuit" In all the programs I have access to I have not found any information on that circuit operation or how to check it. I cancelled that code and it has not returned. It has since thrown codes for steering high pressure cut off, ABS system feed, ASR system feed and the last code was last night code 6 pin 7 which according to the code chart is not applicable to U.S. vehicles. to date none of these codes have returned but pin 19 has had a consistent code 4 air injection system faulty and code 5 egr system faulty. These codes will not cancel for some reason but do not seem to be triggering the light, every time that the light has triggered there has been at least one other code. The clutch on the air pump is working and the pump is pumping air. The egr system seems to be functioning properly except that the passage in the intake manifold is plugged, just discovered that this morning and have not had a chance to r&r the manifold to clean it out. Any ideas why these codes will not cancel and why I keep getting these odd ball codes sporadically. Anyone have any ideas?
I think it's carbon build up. My stealer even had a problem diagnosing it. Finally they removed both heads and cleaned everything out. Expensive, and I'm not saying it's necessary, but the report said that 1 or more air injectors were stopped up, and it did the trick. (It damn well should've after 3 weeks & $3200.)
 

·
Registered
1994 SL500
Joined
·
137 Posts
Discussion Starter #3
Carbon build up yes, fortunately not in the cylinder heads. I had the engine down to the last nut and bolt about 10,000 miles ago. I removed the intake manifold this afternoon and the tube that goes between the upper plenum and lower was completely plugged where it goes into the lower plenum. One of those little things I was unaware of and did not check when the engine went back together. The next problem is what is the sensor on the left cylinder head just behind the left cam advance solenoid connector? That will be the content of the next thread.
 
1 - 3 of 3 Posts
Top