Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Last weekend I drove my '01 C240 6spd. Sedan w/ 25,000 km from Vancouver loaded up with my windsurf gear to go sailing at Harrison Lake (approx 120 km drive).

Was low on fuel so I stopped in for gas. At the first traffic light the "check engine" light came on and motor was idling very rough. Pulled into the closest gas station - a block away and filled up with premium gas.

Put the key in and it wouldn't start! It turned over, but no start. Air lock in gas line I thought? Don't know too much about cars...

Called the Mercedes 1-800 assistance #. Blah blah blah... 45 minutes later a flat deck came out to haul the car back to Vancouver. Since it was great than 80 km I got a rental car... a minivan to carry all my gear. Apparently MB covers upto $600 expenses for these situations.

Well when I got back to work I turned in the rental car and now have an '03 C230 Coupe Auto w/ roof. Well I've had the car all week now!!! They can't figure out whats wrong. Kind of concerned why it's taking so them long. The car starts now, but runs rough. They also performed a "B service"
Think I might sell the car - god knows how much it would cost if it wasn't under warranty!

The C230 is much more fun to drive, but too tiny for me.

Anyone run into a problem similar to this?

dp
 

·
Registered
C230K Sport Sedan
Joined
·
5,368 Posts
It's a Mercedes, that's the norm. Probably a crank position sensor, that's one of the bad ...

It's a Mercedes, that's the norm. Probably a crank position sensor, that's one of the bad boys the engine will run really rough or not at all when it goes bad. Since these cars are problematic I invested in OBD2 scanning software from www.OBD-2.com . It's fairly cheap at a bit over $100.
 

·
Registered
2007 C230 Sport Automatic
Joined
·
35 Posts
Catalytic converters

From my experience, any time a car runs rough, take the catalytic converters off and run the engine (it will be LOUD!) - if it runs fine, you have found your problem.
 

·
Registered
2005 w203, 2013 Town & Country
Joined
·
2,181 Posts
I will say that the exterior of my 2005 C230 exhaust was showing good rust for the mileage (17,000) - So I painted it all last night...
Jake
 
1 - 6 of 6 Posts
Top