Mercedes-Benz Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
This is too much of coincident. My Audi A6 has check engine light on yesterday and my C320 has it on today. The Audi code calls for catalytic converter and C320 shows bad O2 sensors (all 4). The mechanic says there are many incidents (Audi, MB, Jag...) in Boston metro area and it seems to related gas from various bands. Can anyone confirm this?

Thanks.

Ken
 

·
Registered
Joined
·
1 Posts
Bad Gas

I am the person in the interview with WBZ radio! There is a very big potential problem here with cat temps getting really hot!!!! If you can confirm for me that you have any of the following codes in your MB relating to O2 aging time exceeded, above or below threshold value exceeded, or short to signal wire then you must have the tech look at the O2 in actual value. You will find that if you have the contaminate in the fuel your front O2's will be very lazy with values .450mv plus or minus about .075 and rear O2's fixed around .047mv. If this is the case have your tech look at the act temps at idle. If the temps are getting up to the 800 degree f my advice is not to drive the car as I have stated in the news report. There is a potential for fire if this advice is not heeded. WBZ is investigating the situation and would seem that the source at this time is the fuel depot here in Boston. Im really serious about the issue as we do not know as of this writing what the contaminate is yet. I feel confident it is not not ethanol as that test takes only a few minutes to perform and monday I'll test my two samples and let every one know. Stay tuned this is a very serious problem. Audi has been replacing multiple sets of cats and O2 sensors trying to mitigate the problem B4 they and benz got together and determined it is neither mechanical nor electrical. Numerous samples of fuel were tested and found to contain the contaminant!!!!
Stay Tuned

Bob Ansell
 

·
Registered
Joined
·
2 Posts
My check engine light came on about 2 weeks ago and my car (2004 C240) started running poorly. I checked the code and it indicated bad O2 sensors. I brought it to my dealer and they said they've seen many, many cars with the problem. They told me about the gas problem and suggested I run through a couple tanks of gas from a different, name brand, busy station.

David
 

·
Registered
2011 Mercedes E350 4matic Wagon
Joined
·
1,023 Posts
What grade did you get? I got that error once so did my borther in-law with his Audi, when we filled up with 87. The error goes away once the octane of gas boosts up through refills.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
The most recent refill, Sunoco Ultra. I always use the highest grade from brand name stations for both cars. Are you saying the CEL will reset once it goes back to normality?
 

·
Registered
Joined
·
2 Posts
I had been using Sunoco 91 or Ultra 93. I just filled up with 93 octane Mobile and it is still running poorly. The check engine light is still on - sometimes steady, sometimes flashing.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
My CEL just went off on its own without any refill. After this tank, I will do a few small refills from different brands. My car has been running as normal even with fault light on steadily. In some car models, blinking CEL means catalytic converter is in trouble. You may want to check it out.
 

·
Registered
C320 4matic
Joined
·
1,743 Posts
This is not good to hear because I just returned from Boston this weekend and had to fill my car up with 87 because the gas station was out of everything else! Ugh, I'm going to refill and add some STP fuel cleaner before the next run anywhere out of town.
 

·
Registered
2000 Mercedes-Benz S500. Sold: 2000 C230K, Sold: 1997 Porsche 944S
Joined
·
1,271 Posts
This is too much of coincident. My Audi A6 has check engine light on yesterday and my C320 has it on today. The Audi code calls for catalytic converter and C320 shows bad O2 sensors (all 4). The mechanic says there are many incidents (Audi, MB, Jag...) in Boston metro area and it seems to related gas from various bands. Can anyone confirm this?

Thanks.

Ken
Forget the Witch Hunt. Just remember where you fueled up and never visit them again.
Now moving on I recommend the following.

Change out your Fuel Filter
Dump a Bottle of Water Remover in your Gas Tank
Afterwards, run a big jug of Lucas Fuel Conditioner.
It will clean out your Injectors and Fuel System.

If your sensors are still screwey recommend you use a Bottle of CD2 Fuel Emissions Cleaner.

If I had your problem, this is exactly what I would do.
 

·
Registered
Joined
·
3 Posts
2002 c240 caught on fire

Me and my family were on our way to cannobie lake on 93N just past the gas tanks by the big wind fan we had just got $30 of premium gas from the exxon station next to the lincoln mercury dealer at neponset when suddenly the car felt weird I looked through the rear mirror to see a cloud of thick white smoke comming from my car then cars passing me were pointing down to the ground and saying your car is on fire. I pulled over to the break down lane barely getting my wife kids & mother-in-law out of the car before the whole car burt to a crisp.
is there anything that can be done about this :confused:
 

Attachments

·
Registered
2012 C300 4Matic
Joined
·
178 Posts
:eek::eek::eek::eek::eek:
You better get that car to someone who can do some forensics. You better save the receipt from the gas station and make sure you get some kind of proof from the fire department about the time of the fire in relation to your fill up.
Sounds like Exxon owes you a Mercedes.
 

·
Registered
Joined
·
1 Posts
Looks like a serious issue

I got the same problem. Engine Check for some reason. One thing seems to be clear - there is something somewhere in the injection system that negatively affects the performance of the engine. Hard to tell what it is but it seems to be related to quality of gasoline. It is spreading pretty quickly in Boston area, according to my contact. What I am not sure is if this is related exclusively to specific gasoline brand or specific group of gasoline station, and if this has something to do with the rising oil prices for some reasons.
I am very concerned about if and how much the engine of my vehicle got the damage from it and how big and serious the potential impact would be in Boston area. I hope this will not spread. This issue looks mysterious but serious to me.
 

·
Registered
Joined
·
33 Posts
I don't know where the "contamination" occured, but I can envision the tanker company or gas reseller taking cheap (below 87) octane and putting in copious amounts of MMT, Toulene or other octane boosting agent to meet the FTC rated minimum octane.

MMT and other octane boosters will foul your cat and both upstream/downstream 02 sensors. If the Cat is reaching 3x normal temp, that means spent gas is ending up inside the cat unburnt.

All gas distributors fill up at the same depot. Branding starts when you see a big "Shell" or oher major oil company sign on the side of the truck tanker. The raw gas is then brought to a local "warehouse" of sorts where all the addititives and stuff are mixed in.

Gas station inspectors really only check weights and measures, not quality of gas.
 

·
Registered
Joined
·
2 Posts
I don't know where the "contamination" occured, but I can envision the tanker company or gas reseller taking cheap (below 87) octane and putting in copious amounts of MMT, Toulene or other octane boosting agent to meet the FTC rated minimum octane.

MMT and other octane boosters will foul your cat and both upstream/downstream 02 sensors. If the Cat is reaching 3x normal temp, that means spent gas is ending up inside the cat unburnt.

All gas distributors fill up at the same depot. Branding starts when you see a big "Shell" or oher major oil company sign on the side of the truck tanker. The raw gas is then brought to a local "warehouse" of sorts where all the addititives and stuff are mixed in.

Gas station inspectors really only check weights and measures, not quality of gas.
Anyone know if this is still a issue in the boston area?

Thanks
 

·
Registered
C230SS,
Joined
·
261 Posts
I just filled up today ( half tank ) with Shell 89 octane and my CEL came on today. I use the same gasoline station all the time. I checked out the fuel cap and it's on good. Im here in Northern California.
 
1 - 20 of 20 Posts
Top