Mercedes-Benz Forum banner

1 - 16 of 16 Posts

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
Discussion Starter #1
Hi guys,

As some of you may recall my odo stopped working some time ago. I didn't really worry about it because I wasn't going to spend $1200NZ or whatever it is for a new one with my mileage programmed into it from MB. I know a lot of people have had good luck replacing the caps at the back but I’ve also got a dirty great crack down the front that I hate looking at also. Through Miloking here in NZ I can get a digital odo from a S280 for $150.

Has anyone swapped a mechanical one for a digital? If so did you have to adapt the plugs or anything?

Also if anyone has any pictures of the back of either or both a mechanical and digital one that would be great also

Thanks in advance.
 

·
Registered
Current 1992 - 500SEL, W124 - 1989 230E (sold)
Joined
·
1,387 Posts
NZBENZ do you want just the speedo part (the one Benzboss is holding up in last photo) from my "faulty" cluster, iam pretty sure its fine as just the printed circuit board failed (seen in photo #2)
(dont have to pay me anything if it doesnt work and if it does you can buy me a beer when up in auckland :)

BTW thanks BENZBOSS for awesome photos
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
Discussion Starter #5 (Edited)
NZBENZ do you want just the speedo part (the one Benzboss is holding up in last photo) from my "faulty" cluster, iam pretty sure its fine as just the printed circuit board failed (seen in photo #2)
(dont have to pay me anything if it doesnt work and if it does you can buy me a beer when up in auckland :)

BTW thanks BENZBOSS for awesome photos
How many km's are on it? :D Yeah that would be great if they just lift in and out I'd take the plastic also if thats fine so I'd like to pay you something for them both. Your sure that it works and the fault was in another part of the cluster though?

That would be great thanks.

Sorry when I say plastic I mean the clear "glass" window, cover whatever you want to call it.
 

·
Registered
S600L
Joined
·
541 Posts
Mechanical (1992) to digital (1996) straight plug in - changed by MB under warranty at 80k miles when speedo gave up the ghost ;)
 

·
Registered
1987 560SL - 1994 S420 - 2005 S55 AMG
Joined
·
341 Posts
NZBENZ do you want just the speedo part (the one Benzboss is holding up in last photo) from my "faulty" cluster, iam pretty sure its fine as just the printed circuit board failed (seen in photo #2)
(dont have to pay me anything if it doesnt work and if it does you can buy me a beer when up in auckland :)

BTW thanks BENZBOSS for awesome photos
Miloking, can I get the temp/oil pressure cluster? Hopefully it is compatable with a 1994 S420. Please IM me your terms. Thanks in advance, Mslchief
 

·
Registered
Current 1992 - 500SEL, W124 - 1989 230E (sold)
Joined
·
1,387 Posts
mslchief, i have PMed you :) and NZBENZ up to you, you can buy a whole one (digital) as it looks like it will fit just fine (and it should have decent milage as it was 1995). Or yeh you can have both parts(glass and speedo) from my old one (and mslchief will take the temp gauge if he still wants it)
and to answer your questions: it has 233000Km on it (probably double of what you have, so you could try winding it down but better ask about it so it doesnt get damaged)
and that speedo part isnt faulty its the board behind whole cluster powering the whole thing ....i have replaced one of the capacitors that leaked out and about 3 months later whole thing started to flash randomly and then died completely (the flashing lights are pretty much confirm that dead circuit board) so yeh up to you let me know how you decide...
 

·
Registered
Current 1992 - 500SEL, W124 - 1989 230E (sold)
Joined
·
1,387 Posts
yeh NZBENZ looks like iam parting my cluster for sure so i could send you the speedo tomorrow(dont worry about paying me if it doesnt work), but for $150 i would be tempted myself to have digital one :))) (Shame it doesnt work on V8s but iam still glad he had the S420 cluster as i have finaly working clock, heh) is there anything else you need from the car, like some clips,bolts, plastic bits etc?.... he has whole s280 in a garage
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
Discussion Starter #11
Thanks Miloking just a FYI my car has about 225,000km's on the clock... :D Thanks for paying me the compliment though of it having lower km's.

Firstly this may be interesting for people who want to change out their clusters in future:

I emailed a place called mbcluster.com ( www.MBCluster.com Homepage ) and I guess I owe them a plug as they were very helpful. I asked about swapping out clusters here is what they sent to me:

"Glad to receive your message from around the world! Yes, you arecorrect the 104 engine requires clusters made for it, so you should be fine. The only problem you would encounter is a mismatch in pinout. Digitalclusters were introduced in 1994 with the same pinout as yours. However,in mid 1996, they introduced a different pinout which consolidated allmodels to one universal bus. From that point on, compatibility diverged. If your replacement is that type, your out of luck. I have attached apicture of the newer type, which can be identified by two rectangularplugs instead of the type you have now."

So the clusters changed in 1996 to newer plugs like the one below:



And just so we can see the two side by side here is the old one posted by Benzboss (thanks for the pics!)



Just a further note on the dates I know alot of 1994 W140's I've seen here have digital odo's simply because "euro" and by that I mean non North American markets seemed to be about a year ahead so I'd be interested to hear if the dates in the US are perhaps 1995 and 1997 rather than 94 and 96.

Regarding the cluster Miloking can get...When do I have to let you know by I think I will go digital as the other one is likely to die anyway.
 

·
Registered
Current 1992 - 500SEL, W124 - 1989 230E (sold)
Joined
·
1,387 Posts
let me know whenever, the guy is holding the bonnet and cluster till next week for me (as i bought lots of stuff from him already), also if i go and pick it up for you and it ends up having square plug i just wont get it.... (but it cant becuase its 1995 so must be round plug)....otherwise you can have mine whenever you want and since your milage is similar it wont be much of an issue as, i bet you have been driving without speedo for while so 233K will be about right :D
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
Discussion Starter #13
Well it failed at 219 so it's an estimate....hell it's not like the resale values of W140's could get any worse here at the moment though...Mind you alot of the ones for sale are not in great condition. What your proposing sounds good though.
 

·
Registered
Current 1992 - 500SEL, W124 - 1989 230E (sold)
Joined
·
1,387 Posts
well the one i got has 102K kms on it :D so i must have like doubled the value of my car heh
 

·
Registered
Current 1992 - 500SEL, W124 - 1989 230E (sold)
Joined
·
1,387 Posts
you would be surprised how many people dont check it!!!! Even if its just $25
 
1 - 16 of 16 Posts
Top