Mercedes-Benz Forum banner
1 - 10 of 10 Posts

·
Registered
420SEL
Joined
·
1,305 Posts
Discussion Starter · #1 ·
WellI had an oil chaged this weekend, and now for some reason I get 0 oil pressure after the motor gets hot at ilde in gear. It goes right back up to 2-3 as soon as I give it some gas. I did not use MB oil or filter, could it be the problem? Or is it the pressure switch?

Also changed the steering damper, car feels a lot better now. Steering is a bit heavier and more sure footed.
 

·
Registered
92 500SEL to 01 E320T current 2014 lexus LS460
Joined
·
3,886 Posts
The car idles at very low pressure, the manual states that, since it is a dual stage pump. I question why in the world would you not use an MB filter. My dealer does not charge much, under $90 with a filter 9 Qts 5W-50 Mobil synthetic, plus lubing anything that needs it and topping off all fluids. The mechanic looks at things that could become problems!
stay way from the quickies, find a (good) indy if you want to save some money. All the kids know is "music" and how loud it can be.
 

·
Registered
420SEL
Joined
·
1,305 Posts
Discussion Starter · #3 ·
So do you think I should go back and have him put in the MB filter? Or change oil and filter.??
 

·
Registered
94 s420 98 s420
Joined
·
539 Posts
My pressure also stays right above 0 at idle when the car is hot, its a little higher after new oil changes. When I give it gas it goes easly to the 3 mark but never above that. I also never got the low oil pressure ( red ) warning light which I think is when to really be concerned. I use mobil one 0w40 with a german filter. Do you think you had this common problem before you changed your oil but never realaized it?
 

·
Registered
420SEL
Joined
·
1,305 Posts
Discussion Starter · #5 ·
It was close to 0 before oil change, and I was expecting it to get better like it always does with the new oil and filter, but this became worse, now when hot it just sits on 0 when ilde in drive.
I will not play with the motor, I will go and make them do the job over with MB filter and OIL for FREE.
 

·
Registered
420SEL
Joined
·
1,305 Posts
Discussion Starter · #6 ·
Question, 0 pressure cannt actually be 0psi can it? The motor would lock up in that case.
So what does 0-1-2-3 mean, in psi.

Thanks
 

·
Registered
2017 Police Interceptor Utility, 2017 Police Interceptor Sedan
Joined
·
7,750 Posts
Tbilisi79 - 4/2/2006 6:35 PM

Question, 0 pressure cannt actually be 0psi can it? The motor would lock up in that case.
So what does 0-1-2-3 mean, in psi.

Thanks
0=0 atmospheres=0 psi
1=1 atmosphere=15psi
2=2 atmospheres=30psi
3=3 atmospheres=45psi

I think if your engine hasn't become a monolyth yet, you need a new oil pressure switch.
 

·
Registered
94 s420 98 s420
Joined
·
539 Posts
Tbilisi79 - 4/2/2006 7:35 PM

Question, 0 pressure cannt actually be 0psi can it? The motor would lock up in that case.
So what does 0-1-2-3 mean, in psi.

Thanks
I think if it really went to 0 the red light indicator right next to the guage would also light up.
 

·
Registered
420SEL
Joined
·
1,305 Posts
Discussion Starter · #9 ·
I dont have that red light, I have an updated cluster.
 

·
Registered
111/123/124/126/140/201
Joined
·
925 Posts
some mb tech told me as long as the pressure is above 0.3 and it will run up to 3 when u hit the gas it is normal...

my guess is you need a new oil pressure sensor
and why dont you use mb oil filter? it is not expensive anyway...
 
1 - 10 of 10 Posts
Top