Mercedes-Benz Forum banner

Changed front wheel bearings now ESP and ABS warnings are on( E320 CDI)

2197 Views 9 Replies 4 Participants Last post by  mersum1es
while going for a test drive after changing out the front wheel bearings the car threw the ESP and ABS warnings along with a brake visit workshop as well. I have had the brake visit workshop on for a while. Seems to be a huge coincidence that all this happened right after I did the maintenance on the car. I have switched out the brake light switch and that didn't do anything.
1. Could I have possible damaged or had a wheel sensor go bad? I Had to pull each of them out to switch the bearings.​
2. I've had the brake visit workshop for a while. Could the SBC system finally have died out on me and threw all these related codes?​
3. Maybe the ESP module is bad, but the fact that ABS warning accompanied it makes me think it could be something else.​
I have already gone into the menu and disabled the ESP and that doesn't do anything. It lets the car come up to a higher speed ( than with it not being disabled, but the speedometer won't work and it goes into a limp mode along with the steering becoming very stiff.

TIA guys for all the help.
1 - 2 of 10 Posts
Either damaged speed sensor or just wrong gap, system is sensitive to right distance (try search in forum, plenty of discussion). Pulling the codes would be the best since you seems to have some other issues as well...
UPDATE!!!! As mentioned above I had the ABS sensors in after i slid the plastic protective cover in place. I swapped it around slid the sensors in first then secured plastic cover in place and WALA everything is back to normal. Stupid mistake on my end. So just make sure you check the little things when doing jobs like this.
Good you got it working (y)
  • Like
Reactions: 1
1 - 2 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top