Mercedes-Benz Forum banner

1 - 14 of 14 Posts

·
Registered
86 560sec-168K -Ext. Light Ivory/Int. Black/01 E320 4Matic Wagon Brl Silver/Black/ Mad '95 Q45
Joined
·
852 Posts
Discussion Starter #1
it fixed a bevy of issues
belt handlers now work
trunk light works
antenna works
air pump works
seat belt flashing gone
the fuses were all origional and noe the fuse compartment looks pretty;)
 

·
Registered
1988 Mercedes 300SE
Joined
·
61 Posts
hmmm. I would never have guessed. So they all looked ok when you inspected them? I checked a number of mine and they all looked good. Could it be just a little cheese growing in the contacts?
 

·
Registered
86 560sec-168K -Ext. Light Ivory/Int. Black/01 E320 4Matic Wagon Brl Silver/Black/ Mad '95 Q45
Joined
·
852 Posts
Discussion Starter #3
bigdon said:
hmmm. I would never have guessed. So they all looked ok when you inspected them? I checked a number of mine and they all looked good. Could it be just a little cheese growing in the contacts?
thats correct some cheese - i did pay extra attention to #15 cleaned out the holes where the fuse crowns. o yeah it looks pretty
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
How old does a car have to be to benefit from changing the fuses? Mines all working ok but you never know when something might start to go south.
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
420 SE said:
It's not so much an issue of age as one of keeping the contacts clean, and of course, using copper fuses.
Hmmm, mine are the silver ones not copper I guess I should think abotu changing them then?
 

·
Registered
E320
Joined
·
2,798 Posts
oh yes. just buy packages of them from autohausaz.com. they come in cool little pill strips. specify the copper ones. it only costs like $10 to get a whole grip of them. more than you need.
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
NüR-SPEC said:
oh yes. just buy packages of them from autohausaz.com. they come in cool little pill strips. specify the copper ones. it only costs like $10 to get a whole grip of them. more than you need.
Do they come in differnt amps? I'll have to go to my local parts store this weekend and have a look.
 

·
Registered
1982 280 se aut. ecc. - sold
Joined
·
1,607 Posts
jimmypop said:
it fixed a bevy of issues
belt handlers now work
trunk light works
antenna works
air pump works
seat belt flashing gone
the fuses were all origional and noe the fuse compartment looks pretty;)
Told you so!
As stated search function is your friend!

gr J
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
420 SE said:
Except Nat, I couldn't find the 8amp in copper over here, had to get them from the US.
Ok thanks, assuming that I can't get 8amp copper is it ok to run both copper and Al fuses? I'd assume so.
 

·
Premium Member
1990 SEC
Joined
·
4,110 Posts
jimmypop said:
...belt handlers now work...
Yup, that is how you re-set the mechanism.

If your seat belt presenter is acting up, pull the fuse to re-set the mechanism. Simple, cheap. :)
 

·
Registered
86 560sec-168K -Ext. Light Ivory/Int. Black/01 E320 4Matic Wagon Brl Silver/Black/ Mad '95 Q45
Joined
·
852 Posts
Discussion Starter #14
a3jeroen said:
Told you so!
As stated search function is your friend!

gr J
Thats where i saw it, also pitting out 13.8 -14.1 volts now
before changes 13.8 - 12.3v
 
1 - 14 of 14 Posts
Top