Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1996 E320
Joined
·
68 Posts
Discussion Starter #1
So, I have had a small annoying rattle/thunk from the front end for some time, only at lower speeds and only over bumps. Front end tight, no tire wear, no obvious issues. Sounded like sway bar bushings.

I read post after post and the DIY suspension stickie and ordered sway bar bushings and links, as this figured to be the source of my rattle. I got the parts a month ago but kept putting off the install. WHAT WAS I THINKING?!?

I took me less than an hour, and the majority of the time was jacking up and jack-standing the car. I followed the DIY, and it was one of the easiest fixes ever. My old bushings looked like oval charcoal brickets - they were toast.

The result - NO RATTLES or THUNKS. She's back to solid as a rock - she always was solid, just a little noisy. Now I am falling in love with driving this car again.

Don't put it off - Just DO IT !
 

·
Registered
1996 210.020
Joined
·
3,972 Posts
Thanks for the report, Bri. Too bad you don't have pictures to attach.

You should consider getting the alignment checked.
 

·
Registered
CL500, E430, SLK, Subaru...
Joined
·
648 Posts
hm, interesting.

I took the 430 for a bit of a blast last week. It's an Elegance, and my preceding 300 was an Avantgarde (I'm ignoring the 55 for the purposes of this comment!). Across the far northern Dales, there were places where the 430 would bottom a mudflap - places I'd expect even the relatively humble 300TD to spank the ass of any other car on the road. Have I got tired bushes or slack shocks?
 
1 - 3 of 3 Posts
Top