Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
Hi Folks,
any ideas why my passenger door won't lock with the internal locking lever?
If I try to lock using the internal lever, it doesn't stay latched down, just springs back up again. If I lock using the driver's door (which locks drivers door and boot) and I push the passenger door lever down nothing happens, but when it lifts up it unlocks all the doors.
The remote key fob often doesn't do anything at the passenger door, but works fine at boot and drivers. Passenger door locks fine doing this and I can't understand why there is a difference between internal and 'external' locking.
ta
Ade
 

·
Greek God of the R129
Joined
·
8,364 Posts
Hi Folks,
any ideas why my passenger door won't lock with the internal locking lever?
If I try to lock using the internal lever, it doesn't stay latched down, just springs back up again. If I lock using the driver's door (which locks drivers door and boot) and I push the passenger door lever down nothing happens, but when it lifts up it unlocks all the doors.
The remote key fob often doesn't do anything at the passenger door, but works fine at boot and drivers. Passenger door locks fine doing this and I can't understand why there is a difference between internal and 'external' locking.
ta
Ade
If I remember correctly there is a plastic thing in there and is broken.
Open door to see.

Regards.
aam.
 

·
Registered
Joined
·
159 Posts
My 92 300sl has a similar problem. The passenger side internal lock will operate just fine with the engine running or if it is not running. The driver's side will only operate with the engine running. I understand this is a vacuum system so I am guessing that there is some problem on the driver's side, but not bad enough to stop its operation alltogether.
 

·
Greek God of the R129
Joined
·
8,364 Posts
I can't remember if engine has anything to do with the locks.
You have a vacuum pump, located over the battery.

The engine vacuum for the A/C I think is not connected
together, but I been known to make mistakes.

There is a vacuum reserviur hiden in the left fender well, looks
like shoe. Ehehe.

Regards.
aam.
 
1 - 4 of 4 Posts
Top