Mercedes-Benz Forum banner

1 - 17 of 17 Posts

·
Registered
Mercedes 300GD
Joined
·
6 Posts
Discussion Starter #1
I have a mercedes g wagon from '97. (w463)
The problem is that the doors won't lock if you press the button on the remote.
The alarm is turned on, but the doors stay unlocked. I checked all wires, and they are all good. I checked all fuses and they are all good too. So I went to the local mercedes dealer en asked them if they could read out the ECU. But they told me they didn't have the right cables etc... And told me probably no dealer in the Netherlands has that cable. (don't ask me why, I was stunned too). So my guestion is.. Does anyone had this kind of problem and have a solution? Please let me know if you do, because I can't find the problem.
Thanks so much.
 

·
Registered
1996 G320 LWB
Joined
·
126 Posts
Do the power door locks work if you push/pull the drivers door lock pull? Check and make sure all five doors lock to confirm that all five door lock actuators are working.

I had the same problem with he ECU. I think Eurotruck carries an adapter plug so that your MB dealer can plug into the computer port.
 

·
Registered
G320 & E500
Joined
·
1,193 Posts
G-Class said:
I have a mercedes g wagon from '97. (w463)
The problem is that the doors won't lock if you press the button on the remote.
The alarm is turned on, but the doors stay unlocked. I checked all wires, and they are all good. I checked all fuses and they are all good too. So I went to the local mercedes dealer en asked them if they could read out the ECU. But they told me they didn't have the right cables etc... And told me probably no dealer in the Netherlands has that cable. (don't ask me why, I was stunned too). So my guestion is.. Does anyone had this kind of problem and have a solution? Please let me know if you do, because I can't find the problem.
Thanks so much.
Search the P3 site. I have a fix posted there...
 

·
Registered
Mercedes G320 1998
Joined
·
38 Posts
I'm having this same problem in my G320 1998 V6.. press the remote and the alarm activates but the doors won't lock... sit inside and press down on the door lock and none of the others doors lock...
Braingears if you have a moment paste the link of the P3. Thanks
 

·
Registered
Mercedes G320 1998
Joined
·
38 Posts
oh great just found out the gas door lock is on.. shit and how can I bypass this? I need to get some gas in it ASAP :confused:
 

·
Registered
2000 G500 NMLE
Joined
·
6,980 Posts
oh great just found out the gas door lock is on.. shit and how can I bypass this? I need to get some gas in it ASAP :confused:
Go on P3 and post your location and model info. I have a PDF I can send you on how to manually open it.
 

·
Registered
08 ml320 cdi,slk 230,01 boxster S,04 carrera911, 99 S320,67 GT350mustang,02G500L,96 s600 w140
Joined
·
1,669 Posts
Hi guys i have the same exact problem with my 1999 g500. can anyone enlighten me whats a p3? and can i request dutch if you can kindly send me a pdf of the instructions. im not sure if i need to replace my actuators. my problem is that after 3 days of letting the truck sit, the doors wont lock and unlock together. but after starting the car and slamming the door shut and open the locks work again together with the remote. thanks guys.
 

·
Registered
96 G300DT
Joined
·
2,037 Posts
Hi guys i have the same exact problem with my 1999 g500. can anyone enlighten me whats a p3? and can i request dutch if you can kindly send me a pdf of the instructions. im not sure if i need to replace my actuators. my problem is that after 3 days of letting the truck sit, the doors wont lock and unlock together. but after starting the car and slamming the door shut and open the locks work again together with the remote. thanks guys.
"pointed three dot com" - tends to be a better place for technical questions.

As to the lock question, when they work, do they work all together? Or do some work and others fail to move?
 

·
Registered
08 ml320 cdi,slk 230,01 boxster S,04 carrera911, 99 S320,67 GT350mustang,02G500L,96 s600 w140
Joined
·
1,669 Posts
they work all together bro. when it fails everytime i lock it from the driver side door i can hear a faint tick.
 

·
Registered
2000 E55 / 2003 G500 / 2011 BMW M3
Joined
·
776 Posts
From what I have experienced with my 2003 G500, when individual door locks stop functioning correctly (lock but wont unlock, and vise versa) it is probably the individual door lock actuator for that particular door. They are available around $90 online from reputable sellers (mine actually came from MBZ Atlanta online) and I have put two of these on different doors since I have owned this truck.

If on the other hand ALL the door locks are not working as they should, it is probably the door lock control module. I believe that is in the drivers side door (double check that) and is an electrical component. Since you say it works occasionally like when you open or close the door, if it were me, I'd get into that door panel, disconnect all the wire harnesses, spray the crap out of the connectors with electrical contact cleaner, then reattach and test.

Funny how time can corrode connectors just enough to make them act up, and definitely worth a try before buying a new module ... going from memory I think they are around $250 ...
 

·
Registered
96 G300DT
Joined
·
2,037 Posts
Given that the problem affects all the doors equally, it is almost assuredly the central locking module. These can be reconditioned with not too much effort. If you have any soldering skills or know someone who does, have them open up the unit and touch up the solder joints for the two relays found inside. The module is quite low-tech, definitely not rocket science.
 

·
Registered
2000 G55 Classic, 20Series Land Cruiser, 2002 TD5 110 Defender
Joined
·
18 Posts
Resoldering the pins on the control module relay cured my issues and it would be where I would look first. Removing the card is easy enough and even if you are unable to resolver the joints yourself it should not be to hard to find someone else who can do it for you.

Have a look on the P3 forum for details.
 

·
Registered
08 ml320 cdi,slk 230,01 boxster S,04 carrera911, 99 S320,67 GT350mustang,02G500L,96 s600 w140
Joined
·
1,669 Posts
thanks alot guys. would you know the exact location of the module? im gona try to do it myself this weekend. ? if you have pics that would be great. thanks
 

·
Registered
08 ml320 cdi,slk 230,01 boxster S,04 carrera911, 99 S320,67 GT350mustang,02G500L,96 s600 w140
Joined
·
1,669 Posts
Ok. Finally soldered the relay. Saw some loose there. I'll check after a week of hibernation if the problem will be gone. Just had to do t the long way ( had to remove the asc,transmission module and power window module.) I know it's not necessary it's just that I had to look everywhere to locate the lock module.
 

·
Registered
96 G300DT
Joined
·
2,037 Posts
You are looking for this module, which is in the underhood electronics box next to the coolant overflow tank.

All of the locks fail to up at the same time, or just one fails? If they are working differently the problem is more likely in the lock actuators. More recently I found that one of the physical locks had gotten very stiff, to the point that the acuator couldn't push it.
2626740
 
1 - 17 of 17 Posts
Top