Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
2001 CLK55
Joined
·
254 Posts
Discussion Starter #1
Today I turned on my AC for the first time this year and I noticed that the middle vents do not blow. The 2 outer vents seem to blow just fine. But I can't get any air to come out the middle vents. It blows out the top and 2 outside vents. Does anyone have any idea what could be causing this. Even when I cycle through the different air flow positions, it doesn't seem to matter.
 

·
Registered
w208
Joined
·
1,462 Posts
AMGEEZY said:
Today I turned on my AC for the first time this year and I noticed that the middle vents do not blow. The 2 outer vents seem to blow just fine. But I can't get any air to come out the middle vents. It blows out the top and 2 outside vents. Does anyone have any idea what could be causing this. Even when I cycle through the different air flow positions, it doesn't seem to matter.
i have the same prob...
 

·
Registered
Joined
·
1 Posts
My buddy says it is a air control module that goes bad on our cars. Its something that controls the flow of hot and cold air and where and when the vents are open and closed. I dont know if that is the correct name for it but it is something wrong with the "thingy" that controls the air flow.
 

·
Registered
2001 CLK55
Joined
·
254 Posts
Discussion Starter #4
I got it figured out. There is a vaccum hose that runs on the firewall to the intake maniold. The hose was broke where it connected to the manifold. I just cut about a 1/2 an inch off and reconected it. I must have broke it when I was replacing my air filters or clening my MAF. But everything seems to work just fine again,
 
1 - 4 of 4 Posts
Top