Mercedes-Benz Forum banner

1 - 11 of 11 Posts

·
Registered
1995 C280
Joined
·
17 Posts
Discussion Starter #1 (Edited)
Ok, so my check engine light (CEL) turned on today. The car has been running pretty fine, and, even with the light on, I don't feel anything different while driving it. There is no rough idle or jerk or any other symptoms that I can detect. The only abnormaly happened two days ago while I was accelerating onto the freeway when the engine rev'ed up to 4000rpm, but other than that, things seem pretty normal.

I have already made an appointment to have it checked by the end of this week, but I do need this car to get to school. So I wonder if it is still safe to drive the car considering, in my case, that everything seems pretty normal? What are the chances of the car stalling all of a sudden without any signs? Under this circumstance, would you drive the car for the next few days?
 

·
Registered
2004 Lexus LS 430 Modern Luxury. 2012 Acura TSX (fun fun) Maybe MB again one day...
Joined
·
2,604 Posts
It is safe, get the codes pulled for free at an auto parts store.
 

·
Registered
85 300 TDT
Joined
·
2,260 Posts
Finsen,

Don't think it's related to the manual I sent, do you?
 

·
Registered
1995 C280
Joined
·
17 Posts
Discussion Starter #4
Hey Scott, no I don't think it's related to the manual :)
The manual has provided a bit of info on the CEL, it says that if it's on, then something is wrong with the emission control system or the fuel injection system.

I already cleaned the MAF unit today with CRC cleaner but the light is still on. The only thing that puzzles me is that the car has been running fine as usual; I haven't been experiencing any abnormalies like jerk, rough idle, stalling etc... But if the computer says there's something wrong, there is, right?

So, I'll have the car checked tomorrow and see what's up.
 

·
Registered
2004 Lexus LS 430 Modern Luxury. 2012 Acura TSX (fun fun) Maybe MB again one day...
Joined
·
2,604 Posts
You aren't going to necessarily "feel" anything just because the car threw a CEL.

Let us know the code when you get it.
 

·
Registered
2002 ML320
Joined
·
1,951 Posts
This is going to sound elementary and possible stupid... but... worth a shot.

Remove your gas cap and put it back on, making sure it is seated properly. My check engine light came on in my Silverado and I used OnStar to diagnose and they told me that my gas cap was loose. Fixed it and started the truck again and the light never came back.
 

·
Registered
1995 C280
Joined
·
17 Posts
Discussion Starter #7
So here's the update...

So the following codes were pulled:

008
P0116
P0400
S9-1
N3/4

The N3/4 code is for the "HFM control fuel shut-off signal" (anyone knows what this is exactly? Mechanics is asking for 1300+ to change this part saying that the part is expensive). I don't know which code is which, but the other codes associate to air temperature senor, coolant temperature sensor, stop lamp switch, and something HER unit (not entirely sure about this one).

So the mechanic pulled out those codes, but when he used his computer to test each component and test-drove the car, each was doing fine except the HFM unit which was giving a rather ambiguous work/not work result. So now, he cleared the codes and changed the stop lamp switch, and said that if the light comes on again, he'll have to scan again to make sure it is really the HFM being faulty.
 

·
Registered
2004 Lexus LS 430 Modern Luxury. 2012 Acura TSX (fun fun) Maybe MB again one day...
Joined
·
2,604 Posts
Sounds like your throttle actuator may be on the way out. Your tech is right, it is expensive. I'm not sure the book time on the job, probably a couple of hours, maybe less.
 

·
Registered
1995 C280
Joined
·
17 Posts
Discussion Starter #9
So, the HFM control unit has something to do with the fuel injection?? I've tried searching for it, but I can't seem to find results that explain the functionality of that unit. And, how do those symptoms indicate that the throttle actuator is on its way out??
Thanks again!
 

·
W201, W202, W203, W204, W205 Moderator
Amethyst 2001 C320
Joined
·
1,733 Posts
Actually, judging by the fact that you have a 1995, the first thing I'd do before having parts replaced is to replace your engine wiring harness. I'm suspicious that's the problem since so many codes are showing up.
 

·
Registered
2004 Lexus LS 430 Modern Luxury. 2012 Acura TSX (fun fun) Maybe MB again one day...
Joined
·
2,604 Posts
Unfortunately, as I'm sure you know, the throttle actuator has the same crappy wiring inside as well, which fails. But you are right, if the harness has not been replaced it certainly can, and will, cause multiple CEL to be thrown. It should be checked asap.

My car has 113k now and the throttle actuator has not given me any grief yet (touch wood.)
 
1 - 11 of 11 Posts
Top